I have a problem with my Portal captif



  • Hello,

    Im trying to use Portal captif and active directory authentication, but i didn't succeded on it, I think my configuration is wrong, I try to search for help but nothing
    Could u please help me :)

    This is my config :
    Server Address : 192.168.xx.xx
    Server Port : 389
    Identity : CN=Yassine xxx,OU=Employees,OU=Domain Users,DC=xxx,DC=com
    Password : ••••••••••
    Base DN : DC=xxx,DC=com
    Filter : (samAccountName=%{Stripped-User-Name}: -% {User-Name}})
    Base Filter : (&(objectCategory=Person)(samAccountName=*)(memberOf=OU=Employees,OU=Domain Users,DC=xxx,DC=com))



  • @yfarouq:

    …..
    This is my config :
    Server Address : 192.168.xx.xx
    Server Port : 389
    Identity : CN=Yassine xxx,OU=Employees,OU=Domain Users,DC=xxx,DC=com
    Password : ••••••••••
    Base DN : DC=xxx,DC=com
    Filter : (samAccountName=%{Stripped-User-Name}: -% {User-Name}})
    Base Filter : (&(objectCategory=Person)(samAccountName=*)(memberOf=OU=Employees,OU=Domain Users,DC=xxx,DC=com))

    Nice, but what is the problem ?
    Please, saying "doesn't work" won't do. Just a few people use AD authentication, even less visit this forum and a sub-part of that would be able to post IF they could understand what the problem is.



  • When I tried to authenticate with a user from AD, it doesn't work, while when i create a user into freeradius and try to authenticate with it works.

    I think my problem is "Filter" and "Base Filter"



  • Could someone help me please ??????



  • https://forum.pfsense.org/index.php?topic=44689.0

    Have you followed this thread?


Log in to reply