Plex server issue



  • I have a Plex running on Nas which is under 192.168.1.xxx subnet and I need devices under 192.168.2.xxx to be able to see the Plex.

    So far I have setup a firewall rule to allow access from 192.168.2.xxx to 192.168.1.xxx.  I can access the Nas.  But cannot see the Plex service.

    Anyone can tell me how I set this up?

    Thanks



  • This is almost certainly a limitation of, or configuration issue with, Plex. Very unlikely the firewall is actually blocking anything. Turned this up in the Plex forum:

    https://forums.plex.tv/discussion/75810/tv-and-plex-server-on-different-subnets



  • I run a Plex server on my desktop PC and behind a PFSense box. No issues accessing it here on another subnet.

    Are you sure you port forwarded the correct ports to the NAS for Plex? Are you using an ALL policy or port forwarding?



  • @AndroBourne:

    I run a Plex server on my desktop PC and behind a PFSense box. No issues accessing it here on another subnet.

    Are you sure you port forwarded the correct ports to the NAS for Plex? Are you using an ALL policy or port forwarding?

    I am using firewall tulle whereby all traffic on one subnet is accessible on another.

    I have not setup any port forwarding. Not sure a) what port to forward b where to set the port forward in pfsense

    Thanks



  • You could run a TCPView on the station that has plex it see what ports its trying to use.

    Or check here.

    https://support.plex.tv/hc/en-us/articles/201543147-What-network-ports-do-I-need-to-allow-through-my-firewall-

    Also make sure if you are running this on a windows OS that you allow those ports through the local windows firewall as well.



  • @AndroBourne:

    You could run a TCPView on the station that has plex it see what ports its trying to use.

    Or check here.

    https://support.plex.tv/hc/en-us/articles/201543147-What-network-ports-do-I-need-to-allow-through-my-firewall-

    Also make sure if you are running this on a windows OS that you allow those ports through the local windows firewall as well.

    I am running Plex on a Nas box.  So don't think that program will work.  I will have a look at the plex.tv site for ports.  But how do I setup port forwards?


  • Rebel Alliance Global Moderator

    The standard port is 32400.. I access plex without any issues, locally I access it via its local name its running on, ie storage.local.lan:32400

    I have it open to my sons remotely that come in via my public IP on 32400, which I have this rule locked down to their IPs only.  When I am remote and want to access my plex I do so via vpn and then just access storage.local.lan:32400 again.

    Where you can have a problem is your hitting your wan IP for plex and you do not have nat reflection setup.  But your better off just setting up plex.direct to be a local domain so that you don't run into a rebind attack issue.

    In unbound it would be like this
    server:
    private-domain: "plex.direct"

    In the advanced/custom box under unbound (resolver)

    As to "seeing" the plex service - across subnet, no your not going to be able to discover it via some L2/Multicast discovery protocol that is designed for home users when everything is on the same network.  Just hit your plex via its IP:32400 or fqdn:32400 that resolves locally to your local IP.