2.3.4-p1 Breaks PFBlockerNG



  • I upgraded PFSense to 2.3.4-p1 this morning and it broke PFBlockerNG to the point that no traffic would pass through the firewall until I disabled PFBlockerNG. I was also getting errors from that package so I reinstalled it. That didn't change anything so I unchecked the keep settings option and reinstalled again. That got it working.



  • And the rules didn't show up in the firewall until something like ten minutes later.


  • Rebel Alliance Developer Netgate

    Without knowing the exact errors and log entries, there is no way to speculate about the cause or what a fix might have been.

    If anything like that happens again, please include the logs and any error messages from the GUI in your post to help others narrow down the cause of the problem.



  • Here are the errors I was getting.

    /rc.filter_configure_sync: New alert found: There were error(s) loading the rules: /tmp/rules.debug:38: cannot load "/var/db/aliastables/pfB_Top_v4.txt": Invalid argument - The line in question reads [38]: table <pfb_top_v4>persist file "/var/db/aliastables/pfB_Top_v4.txt"

    rc.bootup: New alert found: There were error(s) loading the rules: /tmp/rules.debug:38: cannot load "/var/db/aliastables/pfB_Top_v4.txt": Invalid argument - The line in question reads [38]: table <pfb_top_v4>persist file "/var/db/aliastables/pfB_Top_v4.txt"

    /rc.filter_configure_sync: The command '/sbin/pfctl -nf /tmp/rules.test.packages' returned exit code '1', the output was '/tmp/rules.test.packages:33: cannot load "/var/db/aliastables/pfB_Top_v4.txt": Invalid argument'

    rc.bootup: The command '/sbin/pfctl -nf /tmp/rules.test.packages' returned exit code '1', the output was '/tmp/rules.test.packages:33: cannot load "/var/db/aliastables/pfB_Top_v4.txt": Invalid argument'</pfb_top_v4></pfb_top_v4>



  • I normally disable pfBlockerNG and Suricata when I update pfsense, this way nothing block internet access.
    Once the update is done, I re-enable them.
    pfblockerng might need a Force reload all to get back on it's feet after being enabled.



  • Just to confirm that I had the same problem, I disabled PFBlockerNG and did a force reload as RonpfS suggested then enabled it again and all OK now.