Operation timed out



  • i have try update many versions always fail.

    Updating repositories metadata…
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.

    Unlocking package pfSense-kernel-pfSense... done.
    Downloading upgrade packages...
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking for upgrades (9 candidates): ......... done
    Processing candidates (9 candidates): ......... done
    The following 8 package(s) will be affected (of 0 checked):

    Installed packages to be UPGRADED:
    strongswan: 5.5.2_1 -> 5.5.3 [pfSense]
    php56-pfSense-module: 0.45 -> 0.47 [pfSense]
    pfSense-rc: 2.4.0.b.20170722.0215 -> 2.4.0.b.20170731.1917 [pfSense-core]
    pfSense-kernel-pfSense: 2.4.0.b.20170722.0215 -> 2.4.0.b.20170731.1917 [pfSense-core]
    pfSense-default-config: 2.4.0.b.20170722.0215 -> 2.4.0.b.20170731.1917 [pfSense-core]
    pfSense-base: 2.4.0.b.20170722.0215 -> 2.4.0.b.20170731.1917 [pfSense-core]
    pfSense: 2.4.0.b.20170721.1400 -> 2.4.0.b.20170731.1405 [pfSense]
    ldns: 1.7.0 -> 1.7.0_1 [pfSense]

    Number of packages to be upgraded: 8

    The operation will free 3 MiB.
    51 MiB to be downloaded.
    [1/8] Fetching pfSense-kernel-pfSense-2.4.0.b.20170731.1917.txz: . done
    pkg: https://beta.pfsense.org/packages/pfSense_master_amd64-core/All/pfSense-kernel-pfSense-2.4.0.b.20170731.1917.txz: Operation timed out

    Locking package pfSense-kernel-pfSense… done.
    Failed



  • Always fail many problems make you.. (as Yoda would say..)
    Is all text you put in the forum a copy paste from whatever google translate delivers.?.

    Anyhow.. are you on a really slow internet connection? Do downloads from other websites work properly? Can you fetch or curl the files available on the website https://beta.pfsense.org/packages/pfSense_master_amd64-core/All/ ?
    What have you done to troubleshoot and resolve the issue sofar?



  • Make sure you don't try to upgrade over IPv6. That did not work for me.
    Upgrade over IPv4 worked fine.



  • Clean cache before executing upgrade.
    Diagnostics / Command Prompt

    pkg clean -a -y
    


  • Did a few things, but it seemed a combination of setting IPv4 as the preferred transport, and clearing out the pkg repository, finally did the trick.


Log in to reply