4G/LTE support



  • I am new to pfSense and trying to get an u-blox TOBY-L210 4G/LTE miniPCIe modem working with pfSense 2.3.4.  It would be best to use a virtual Ethernet driver provided by the modem (this works under linux), but no such interface is visible under FreeBSD.  Here's what dmesg says about the modem:

    ugen0.2: <u-blox>at usbus0
    umodem0: <cdc abstract="" control="" model="" acm="">on usbus0
    umodem0: data interface 3, has no CM over data, has no break

    I have tried to set up PPP using /dev/cuau0 and /dev/cuaU0, but neither one seems to respond to AT commands (I have no idea if either device is actually linked to the modem).  No other devices are selectable for PPP.

    I'm using a Qotom PC with four Ethernet ports, SSD disks and the u-blox modem.

    Is there something I could do - other than dropping pfSense and using linux as a gateway?

    Thanks!</cdc></u-blox>



  • LTE is not really supported by pfSense as you can see - I have tried to use LTE modems for years but no way got it working. I just switched to Teltonika Linux box: https://teltonika.lt/product/rut950/

    This was easy and it took only 5min to configure. Just selected my operator and sim pin code and thats it. Ipsec VPN was up in few minutes too.

    pfSense is not the way to go if you are planing to use LTE modems in any way. Sad but so true.

    Look at the posts here - everyone is playing with ppp problems and no one has real working solution. If you want to play and waste you time - then pfSense is good for you. I hope that someone figures and fixed his general problem with 4G/5G modems- Modems just are one main parts telecommunication and sad to see that pfSense is having huge problems with it.



  • Seriously- Id pick up a Cradlepoint device and put it in bridge mode. https://cradlepoint.com/iot-routers

    They are a bit spendy but they are very resilient. There are some other choices but this is the only one Im familiar with.



  • Looks nice devices! Sad that work-around is to buy middleware router. Your right - this is good option.



  • @clouseau

    My kids busted my reading glasses so I missed the link you provided above. Is your device able to go into a bridge mode? Looks interesting.

    Even the TOBY modem biterror is trying to use looks like fun. But no external antenna ports? Not an option with me here Im afraid.


  • Rebel Alliance

    I have had good success pushing OpenVPN form 4G Routers running OpenWRT / LuCi.
    http://www.proroute.co.uk/proroute-4g-routers/proroute-h685-4g-lte-router/
    or;
    https://comset.com.au/4g-lte-modem-routers-c-65/