None2@pci - missing wireless device



  • i have recently got a new box to put my pfsense on (moving from an old pc to a dedicated box)

    anyway the all in one box, like the SG-2440 has an inbuilt wireless card

    when i run

    pciconf -l -v

    i can see the device as

    none2@pci0:4:0:0 blah blah etc

    But i can't see this at all anywhere in the pfsense  GUI, how do i add this as the wireless interface?

    IIRC , the wireless card is 802.11ac, assuming this might be a driver problem?


  • Rebel Alliance Developer Netgate

    That means there is no driver available for that card.

    You can try a 2.4 snapshot, but it's possible that there is no driver for FreeBSD at all, or perhaps that it isn't present in our builds.

    Do you know what make/model card that is, specifically? If you post the full "pciconf -lvb" output for it, the card and chipid should let you find what it is.



  • there are a few none@

    but the none2@pci is as follows:-

    
    none2@pci0:4:0:0:	class=0x028000 card=0x00708086 chip=0x08b38086 rev=0x83 hdr=0x00
        vendor     = 'Intel Corporation'
        device     = 'Wireless 3160'
        class      = network
        bar   [10] = type Memory, range 64, base 0xf7900000, size 8192, enabled
    
    

  • Rebel Alliance Developer Netgate

    We don't have a driver for that one, but it may make it into 2.4.x at some point: https://redmine.pfsense.org/issues/7725



  • just updated, still not supported  :(

    fingers crossed in a future build….