How to Clear Settings - Redundant VPN Client Setup



  • Connection problems are happening frequently on our 24 hour VPN client so I am trying to setup redundant VPN clients in a gateway group (all tier 1). This is to 3 different servers, all with the exact same settings. Somehow the first connection setup worked but nothing else will now, even one at a time. It is like OpenVPN is setup for the one now and not changing when the others are tried. I can connect to those servers on other devices though!

    My first VPN connection works, but the other two do not. They are setup as gateway group, all sharing the tier 1 tier. Other than the original working VPN connection, the other two either say down or up and not connected. All have the gateway set to be dynamic but only the first one has an IP, the others usually say pending, status unknown on the dashboard.

    I tried to enable one at a time and can't get any of non-working ones to work, they don't and the dynamic gateways still don't get an IP. I went so far as to eliminate the group and just do the 2nd and 3rd VPNs with individual gateways and that doesn't work either.

    Perplexed as I checked the guide I followed (link below), I tried keeping all the settings for the working VPN the same and substituted the certificate and key. That SHOULD work since all the servers have the same settings. It doesn't change anything though so I figure that perhaps some routing is messed up somewhere, maybe the settings from the first are being used for the second and third somehow. I am not privy to all the inner workings of OpenVPN, but I figured a good start might be to clear all the settings and start over. I am not finding a way online to do that after a lot of searching. Any ideas on how to do that or fix this? It has been a problem for months and is getting VERY old.

    I have seen  various error messages in OpenVPN's log,  there is something else going on, not just what the error message right now says. Generally they keep repeating. I think one said CMD State=1, a lot of Sig received, closing connection type messages.

    Really think that there is some config that is being retained which allows the 1st to work but not the others.



  • I forgot to add the link to the instructions I used for the Multi-VPN WAN as he/she puts it. I used the guide for my general sedtup and customized it a bit, substituting NordVPN's client setup for AirVPN's.

    https://nguvu.org/pfsense/pfsense-multi-vpn-wan/

    I am thinking perhaps I should have put this in the General Section to get more views and perhaps help with the gateway aspect. I would be happy here with a start of how to just reset openVPN's setup to default. Looking into perhaps deleting OpenVPN completely and reinstalling. Might make things worse though.