Implementación de pfsense en red con varias LAN



  • Saludos, estoy implementando pfsense en mi red en donde se tenia unidas varias sedes con la central mediante módem L2L Cisco estos están en modo transparente y no filtran ninguna comunicación y tienen sus ip propias y la sede central también tiene un módem Cisco L2L y aquí esta el router Cisco que da acceso a Internet a las demás redes

    RED_PRINCIPAL
    IP WAN=190.X.Y.Z/27
    IP LAN=172.15.10.221/24
    L2L= 192.168.110.0/24

    SEDE01
    172.15.20.0/24 (IP)
    172.15.10.28 (GW)

    SEDE02
    172.15.30.0/24 (IP)
    172.15.10.28 (GW)

    SEDE03
    172.15.40.0/24 (IP)
    172.15.10.28 (GW)

    SEDEEXTRA
    192.168.110.0/24 (IP)
    172.15.10.28 (GW)

    Y el proveedor me recomienda que la configuración que esta en el router Cisco la recree en el pfsense a los que me envío una copia de la configuración la cual es la siguiente:

    interface FastEthernet0/1
    description Interface LAN
    ip address 172.15.10.221 255.255.255.0 secondary
    ip address 191.x.y.z 255.255.255.240

    ip forward-protocol nd
    ip route 172.15.20.0 255.255.255.0 172.15.10.28 name SEDE02
    ip route 172.15.30.0 255.255.255.0 172.15.10.28 name SEDE03
    ip route 172.15.40.0 255.255.255.0 172.15.10.28 name SEDE04
    ip route 192.168.110.0 255.255.255.0 172.15.10.28 name CNX_SEDE_EXTRA

    ip nat inside source list 10 interface FastEthernet0/1 overload
    ip nat inside source static tcp 172.15.20.175 22 191.x.y.z 22 extendable
    ip nat inside source static tcp 172.15.20.175 80 191.x.y.z 80 extendable
    ip nat inside source static tcp 172.15.20.175 5432 191.x.y.z 5432 extendable

    Alguien podría decirme en que módulos debería de configurarse esto, pues yo asumo en el primer párrafo es la IP WAN y LAN, el segundo párrafo lo entiendo como tablas de ruteo y el ultimo como NAT de firewall. Ojala me puedan ayudar.



  • Buen día

    Podrías poner un diagrama con la topología física como está actualmente?, el router que comunica con otras sedes, es el mismo de internet?., si es así, tal vez tengas que manejar VLANS en la WAN

    Saludos.



  • Saludos, disculpa la demora aqui te adjunto el diagrama de red (diagrama.png)




  • Baje la imagen y no logro distinguir las IP, un tu primer post lo que no entiendo que es el tercer párrafo.



  • Lo interpreto asi:

    1)Debes setear la WAN en tu pfsense la cual debería ser:  190.X.Y.Z/27  (/27 es un pool amplio de IP Publicas fija).

    1. La LAN del Pfsense:  IP LAN=172.15.10.221/24

    2. Tus sede remotas no son VLAN,  yo las veo como Redes de Metro Ethernet dedicadas, por lo que todo girara en torno a rutas estáticas en su pfsense, osea estas:

    ip route 172.15.20.0 255.255.255.0 172.15.10.28 name SEDE02
    ip route 172.15.30.0 255.255.255.0 172.15.10.28 name SEDE03
    ip route 172.15.40.0 255.255.255.0 172.15.10.28 name SEDE04
    ip route 192.168.110.0 255.255.255.0 172.15.10.28 name CNX_SEDE_EXTRA

    1. Quien es y donde esta (no lo veo en el gráfico)  172.15.10.28    Valida si con pfsense desde la LAN (172.15.10.22) la vez.    Ya que para llegar a las Sedes 2,3 y 4,  debes pasar por 172.15.10.28, quiere decir que lo mas probable es que en pfsense debas crear un gateway (no debe ser default) con la IP 172.15.10.28    y luego pasar las rutas 20.0  30.0  y  40.0  por alli.

    2. Que hace la interfaz:  L2L= 192.168.110.0/24  ????  no me dice mucho,  aunque tambien para conocerla debes pasar por el gw 172.15.10.28

    L2L= 192.168.110.0/24  parece mas una red que debes declarar y pasarla por el gw.

    Ahora, viendo esto al final:

    interface FastEthernet0/1
    description Interface LAN
    ip address 172.15.10.221 255.255.255.0 secondary
    ip address 191.x.y.z 255.255.255.240

    ####Me dice que tu pfsene debe comportarse como un fiurewall-router. ######

    PARA MI ES MAS FACIL QUE EL PROVEEDOR ISP TE MANDE LOS DATOS DE CONEXIÓN O DEL CIRCUITO,  QUE UN show run config.

    Si te lo envian, lo pegas aqui y podemos verlo mejor.



  • Saludos j.sejo1 gracias por la ayuda te comento

    1. el router de mi proveedor lo ponemos en modo bridge así pfsense tome la ip publica y demás direcciones

    3. Exacto en el pfsense se creo un gateway con ip = 172.15.10.28 con interface LAN y se crearon las rutas estáticas todas con el gateway 172.15.10.28

    4. Lo consulte y me dijeron que era el gateway de todas los módem L2L pero no me indicaron si era un dispositivo

    5. si exacto, ni ellos mismos sabe solo me dicen que la anterior gestión lo solicito pero igual cree el ruteo para esa dirección 192.168.110.0/24 con gateway 172.15.10.28

    PARA MI ES MAS FÁCIL QUE EL PROVEEDOR ISP TE MANDE LOS DATOS DE CONEXIÓN O DEL CIRCUITO

    Si, eso lo haré mañana a fin de tener mas claro el panorama y estaré posteando ojala me puedas dar una ayuda, desde ya muchísimas gracias.