OpenVPN force all traffic through tunnel - fails



  • Guys, I am stumped. After trying for 2-days I can't seem to get OpenVPN to work when I set the server to force all traffic through the gateway.

    OpenVPN server works on one client: TCP-443, not forced to route through the VPN and no pushing of DNS server.

    My other VPN server (UDP-1164) that does force traffic through the VPN connects, but nothing resolves or routes. I can't ping the gateway; I can't resolve DNS. I've tried changing the DNS to 8.8.8.8 – still nothing.

    I used the OpenDNS wizard for both and let it create both rules.

    VPN IP is 10.0.0.1
    LAN is 10.1.1.0/24 (gateway 10.1.1.200)

    I can't even ping 10.1.1.200.

    pfsense is running on a netgate box with pfblockerNG, snort configured.

    Hoping someone can point me in the right direction - I'm at my wit's end!

    Thanks!!

    Edit: Interestingly enough, I'm seeing blocked entries in the firewall not from the openvpn interface, but from the WAN with the IP address of the remote client. Shows blocked to the public/WAN IP of the pfsense appliance. That doesn't seem right. Shouldn't the interface show openvpn?

    Edit 2: Now it's still not working but not showing any entries in the firewall log. Not sure what the blip above was. idk what is going on.