Pppoe closing every 2 days isp or pfsense? and edit: also ipv6 settings issue



  • pppoe connections closing every 2 days roughly with this in log

    Aug 27 17:09:39 ppp [wan_link0] PPPoE: connection closed

    also tries for ipv6 even though i have it set to none?

    Time Process PID Message
    Aug 27 17:10:05 ppp [wan] IPV6CP: LayerFinish
    Aug 27 17:10:05 ppp [wan] IPV6CP: state change Req-Sent –> Stopped
    Aug 27 17:10:05 ppp [wan] IPV6CP: parameter negotiation failed
    Aug 27 17:10:03 ppp [wan] IPV6CP: SendConfigReq #20
    Aug 27 17:10:01 ppp [wan] IPV6CP: SendConfigReq #19
    Aug 27 17:09:59 ppp [wan] IPV6CP: SendConfigReq #18
    Aug 27 17:09:57 ppp [wan] IPV6CP: SendConfigReq #17
    Aug 27 17:09:55 ppp [wan] IPV6CP: SendConfigReq #16
    Aug 27 17:09:53 ppp [wan] IPV6CP: SendConfigReq #15
    Aug 27 17:09:51 ppp [wan] IPV6CP: SendConfigReq #14
    Aug 27 17:09:49 ppp [wan] IPV6CP: SendConfigReq #13
    Aug 27 17:09:47 ppp [wan] IPV6CP: SendConfigReq #12



  • does not match user interface

    mpd_wan.conf

    startup:

    configure the console

    set console close

    configure the web server

    set web close

    default:
    pppoeclient:
    create bundle static wan
    set bundle enable ipv6cp
    set iface name pppoe0
    set iface route default
    set iface disable on-demand
    set iface idle 0
    set iface enable tcpmssfix
    set iface up-script /usr/local/sbin/ppp-linkup
    set iface down-script /usr/local/sbin/ppp-linkdown
    set ipcp ranges 0.0.0.0/0 0.0.0.0/0
    #log -bund -ccp -chat -iface -ipcp -lcp -link

    create link static wan_link0 pppoe
    set link action bundle wan
    set link disable multilink
    set link keep-alive 10 60
    set link max-redial 0
    set link disable chap pap
    set link accept chap pap eap
    set link disable incoming
    set link mtu 1492
    set auth authname "xxxxxxx@windstream.net"
    set auth password xxxxxxx
    set pppoe service ""
    set pppoe iface igb0
    open



  • gui mismatched mpd conf see attached files

    ![Screen Shot 2017-08-27 at 8.38.45 PM.png](/public/imported_attachments/1/Screen Shot 2017-08-27 at 8.38.45 PM.png)
    ![Screen Shot 2017-08-27 at 8.38.45 PM.png_thumb](/public/imported_attachments/1/Screen Shot 2017-08-27 at 8.38.45 PM.png_thumb)
    ![Screen Shot 2017-08-27 at 8.39.43 PM.png](/public/imported_attachments/1/Screen Shot 2017-08-27 at 8.39.43 PM.png)
    ![Screen Shot 2017-08-27 at 8.39.43 PM.png_thumb](/public/imported_attachments/1/Screen Shot 2017-08-27 at 8.39.43 PM.png_thumb)



  • any help / advice ?




  • Banned

    @grandrivers:

    https://redmine.pfsense.org/issues/7822

    And how's that related to "pppoe closing every 2 days"?



  • well its most likely isp, most likely I titled it poorly, I was troubling pppoe issue and noticed that too wonder what other settings my not transfer correctly from gui to config file ??

    I don't code and am not too familiar with mpd5.8 config



  • this is a pfsense issue when isp closes it it says connection terminated where this says connection closed
    cant seem to find the what that triggers it

    ipv6 pointed out in this thread
    https://forum.pfsense.org/index.php?topic=126849.msg700559#msg700559



  • went and copied my mpd.conf file to cf/conf/  edited the enable to disable and turned off ipv6


Log in to reply