Ntopng redis issues



  • Having some issues getting redis to start/work with the ntop pkg v0.8.10. I've tried a fresh install and still having the same problem. Don't have any other packages using redis. Posted the logs below. Any help would be appreciated.

    2.4.0-RC (amd64)
    built on Tue Aug 29 09:29:29 CDT 2017
    FreeBSD 11.0-RELEASE-p12


    ntopng 		[Redis.cpp:97] ERROR: to specify a redis server other than the default
    ntopng 		[Redis.cpp:96] ERROR: Please start it and try again or use -r
    ntopng 		[Redis.cpp:95] ERROR: ntopng requires redis server to be up and running
    php-fpm 	19582 	/pkg_edit.php: The command '/usr/local/bin/redis-cli save' returned exit code '1', the output was 'Could not connect to Redis at 127.0.0.1:6379: Can't assign requested address'
    php-fpm 	19582 	/pkg_edit.php: The command '/usr/local/bin/redis-cli SET ntopng.user.admin.group administrator' returned exit code '1', the output was 'Could not connect to Redis at 127.0.0.1:6379: Can't assign requested address'
    php-fpm 	19582 	/pkg_edit.php: The command '/usr/local/bin/redis-cli SET ntopng.user.admin.password '[i]redacted[/i]'' returned exit code '1', the output was 'Could not connect to Redis at 127.0.0.1:6379: Can't assign requested address' 
    


  • me too… I turned it off...

    it never started using port  :3000.. i had to go into the settings first then apply or save then ntop works...

    and the last release 100% cpu hits


  • Banned

    @bobwright:

    Having some issues getting redis to start/work with the ntop pkg v0.8.10. I've tried a fresh install and still having the same problem.

    It's already running. Fresh install won't do any good unless you wipe the (very likely broken) DB.

    1/ Uninstall the package,

    2/ Nuke the data - which is very likely broken so nothing works any more (this happens about weekly here due to the "quality" of Redis, so I simply gave up on using this thing)

    
    rm -rf /var/db/ntopng
    
    

    3/ Reinstall the package and reconfigure.



  • I tried doing that again and still not working. No big deal. Thanks for the help.



  • @doktornotor Thanks this worked for me