Inplace install of pfsense 2.40RC 08/31 DQ77KB works ok except ntopng



  • Hi,

    I just upgraded from 2.3.4p1 to 2.4.0RC and everything is working fine after reboot except ntopng. OpenVPN is ok from iOS OpenVPN Connect without modifications over udp/TCP. No runaway processes or memory overload. Home fw 6 people. Thank you!

    Sys:
    Intel DQ77KB
    Intel(R) Xeon(R) CPU E3-1265L V2 @ 2.50GHz
    8 CPUs: 1 package(s) x 4 core(s) x 2 hardware threads
    AES-NI CPU Crypto: Yes (active)

    System activity:
    last pid: 13737;  load averages:  0.27,  0.50,  0.27  up 0+00:03:55    17:57:05
    241 processes: 9 running, 201 sleeping, 31 waiting

    Mem: 93M Active, 75M Inact, 424M Wired, 210M Buf, 7152M Free
    Swap: 16G Total, 16G Free

    PID USERNAME      PRI NICE  SIZE    RES STATE  C  TIME    WCPU COMMAND
      11 root          155 ki31    0K  128K CPU0    0  3:49 100.00%            [idle{idle: cpu0}]
      11 root          155 ki31    0K  128K CPU2    2  3:41 100.00%            [idle{idle: cpu2}]
      11 root          155 ki31    0K  128K RUN    7  3:40 100.00%            [idle{idle: cpu7}]
      11 root          155 ki31    0K  128K CPU3    3  3:39 100.00%            [idle{idle: cpu3}]
      11 root          155 ki31    0K  128K CPU6    6  3:38 100.00%            [idle{idle: cpu6}]
      11 root          155 ki31    0K  128K CPU1    1  3:37 100.00%            [idle{idle: cpu1}]
      11 root          155 ki31    0K  128K CPU5    5  3:35 100.00%            [idle{idle: cpu5}]
      11 root          155 ki31    0K  128K CPU4    4  3:32 100.00%            [idle{idle: cpu4}]
    77749 root          28    0  284M 38236K piperd  0  0:00  0.59% php-fpm:  pool nginx (php-fpm)
        0 root          -16    -    0K  368K swapin  0  0:30  0.00%            [kernel{swapper}]
      12 root          -92    -    0K  496K WAIT    0  0:01  0.00%            [intr{irq267: em1:rx0}]
      12 root          -60    -    0K  496K WAIT    0  0:01  0.00%            [intr{swi4: clock (0)}]
        0 root          -92    -    0K  368K -      4  0:00  0.00%            [kernel{em0 que}]
      12 root          -88    -    0K  496K WAIT    2  0:00  0.00%            [intr{irq270: ahci0}]
    28020 unbound        20    0  102M 55708K kqread  0  0:00  0.00% /usr/local/sbin/unbound -c /var/unbou
        7 root          -16    -    0K    16K -      6  0:00  0.00%            [rand_harvestq]
    44874 root          20    0 37636K  8336K kqread  7  0:00  0.00% nginx:    worker process (nginx)
    46027 root          20    0 24568K 12416K select  5  0:00  0.00% /usr/local/sbin/ntpd -g -c /var/etc/n

    –---

    System log excerpts about ntopng:

    Aug 31 17:54:37 kernel    em0: promiscuous mode disabled
    Aug 31 17:54:37 kernel    pid 96461 (ntopng), uid 0: exited on signal 11 (core dumped)
    Aug 31 17:54:35 php  /etc/rc.packages: The command '/bin/cp -Rp /usr/local/  lib/X11/fonts/webfonts/ /usr/local/lib/X11/fonts/TTF/' returned exit code '1', the output was 'cp: directory /usr/local/lib/X11/fonts/TTF does not exist'
    Aug 31 17:54:35 php  /etc/rc.packages: Beginning package installation for    ntopng .
    Aug 31 17:54:35 pkg  pfSense-pkg-openvpn-client-export reinstalled: 1.4.12 -> 1.4.12
    Aug 31 17:54:35 php  /etc/rc.packages: Successfully installed package:        OpenVPN Client Export Utility.

    ...

    Aug 31 17:54:08 php  [pfBlockerNG] Starting cron process.
    Aug 31 17:54:08 check_reload_status  Syncing firewall
    Aug 31 17:54:08 kernel    …. done
    Aug 31 17:54:07 ntopng    [HTTPserver.cpp:806] ERROR: Unable to start HTTP    server (IPv4) on ports 3000s
    Aug 31 17:54:07 ntopng    [mongoose.c:4515] ERROR: set_ports_option: cannot    bind to 3000s: Address already in use
    Aug 31 17:53:47 kernel    em0: promiscuous mode enabled



  • I also get some errors in LOG for ntopng:

    Sep 1 09:05:01 ntopng [HTTPserver.cpp:806] ERROR: Unable to start HTTP server (IPv4) on ports 3000s
    Sep 1 09:05:01 ntopng [mongoose.c:4515] ERROR: set_ports_option: cannot bind to 3000s: Address already in use
    Sep 1 08:59:38 ntopng [HTTPserver.cpp:806] ERROR: Unable to start HTTP server (IPv4) on ports 3000s
    Sep 1 08:59:38 ntopng [mongoose.c:4515] ERROR: set_ports_option: cannot bind to 3000s: Address already in use
    Sep 1 08:59:18 ntopng [HTTPserver.cpp:806] ERROR: Unable to start HTTP server (IPv4) on ports 3000s
    Sep 1 08:59:18 ntopng [mongoose.c:4515] ERROR: set_ports_option: cannot bind to 3000s: Address already in use
    Aug 31 21:05:08 ntopng [Lua.cpp:6467] WARNING: Script failure [/usr/local/share/ntopng/scripts/lua/index.lua][/usr/local/share/ntopng/scripts/lua/index.lua:42: attempt to concatenate global 'ifname' (a nil value)]

    Once I log in, I see the attached, but going to Dashboard works.




  • Also, if I navigate to http://192.168.2.1:3000  I get "The connection was reset". Before, it would redirect to the login page.
    Going from pfSense>Diagnostics>ntopng takes me directly to the login page.


Log in to reply