Can't upgrade from 2.4 beta snapshots to 2.4 RC



  • A week or so ago, I tried to update via the GUI, but after a reboot, I was still on 2.4 BETA.

    I just tried again, and then via SSH, and it still won't upgrade. I've checked, I'm on the Stable branch in settings. Log output for a manual update on SSH:

    [2.4.0-BETA][admin@gandalf]/root: pkg update -f
    Updating pfSense-core repository catalogue…
    Fetching meta.txz: 100%    944 B  0.9kB/s    00:01
    Fetching packagesite.txz: 100%    2 KiB  1.7kB/s    00:01
    Processing entries: 100%
    pfSense-core repository update completed. 7 packages processed.
    Updating pfSense repository catalogue...
    Fetching meta.txz: 100%    944 B  0.9kB/s    00:01
    Fetching packagesite.txz: 100%  128 KiB 131.2kB/s    00:01
    Processing entries: 100%
    pfSense repository update completed. 480 packages processed.
    All repositories are up to date.
    [2.4.0-BETA][admin@gandalf]/root: pfSense-upgrade -d

    Updating repositories metadata…
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.

    Unlocking package pfSense-kernel-pfSense...
    Unlocking pfSense-kernel-pfSense-2.4.0.r.20170904.0902
    The following 21 package(s) will be affected (of 0 checked):

    Installed packages to be REMOVED:
    oniguruma5-5.9.6_1

    New packages to be INSTALLED:
    oniguruma6: 6.4.0 [pfSense]
    pecl-ssh2-0: 0.13 [pfSense]
    libssh2: 1.8.0,3 [pfSense]

    Installed packages to be UPGRADED:
    strongswan: 5.5.2_1 -> 5.5.3 [pfSense]
    sqlite3: 3.19.3_1 -> 3.20.0_1 [pfSense]
    python27: 2.7.13_6 -> 2.7.13_7 [pfSense]
    php56-pfSense-module: 0.46 -> 0.48 [pfSense]
    php56-mbstring: 5.6.31 -> 5.6.31_1 [pfSense]
    pfSense-pkg-pfBlockerNG: 2.1.1_8 -> 2.1.1_10 [pfSense]
    pfSense-pkg-nut: 2.7.4_4 -> 2.7.4_5 [pfSense]
    pfSense-pkg-acme: 0.1.18 -> 0.1.19 [pfSense]
    pfSense-default-config: 2.4.0.b.20170724.1206 -> 2.4.0.r.20170904.0902 [pfSense-core]
    pfSense-base: 2.4.0.b.20170724.1206 -> 2.4.0.r.20170904.0902 [pfSense-core]
    pfSense-Status_Monitoring: 1.7.0_3 -> 1.7.1_3 [pfSense]
    pfSense: 2.4.0.b.20170724.1206 -> 2.4.0.r.20170903.1625 [pfSense]
    libidn2: 2.0.2 -> 2.0.3 [pfSense]
    ldns: 1.7.0 -> 1.7.0_1 [pfSense]
    curl: 7.54.1 -> 7.55.1 [pfSense]
    ca_root_nss: 3.31 -> 3.32 [pfSense]

    Installed packages to be REINSTALLED:
    pkg-1.10.1_1 [pfSense]

    Number of packages to be removed: 1
    Number of packages to be installed: 3
    Number of packages to be upgraded: 16
    Number of packages to be reinstalled: 1

    The operation will free 2 MiB.
    3 MiB to be downloaded.

    **** WARNING ****
    Reboot will be required!!
    Proceed with upgrade? (y/N) y

    Downloading upgrade packages…
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking for upgrades (17 candidates): .......... done
    Processing candidates (17 candidates): .......... done
    Checking integrity... done (1 conflicting)
      - oniguruma6-6.4.0 [pfSense] conflicts with oniguruma5-5.9.6_1 [installed] on /usr/local/bin/onig-config
    Checking integrity… done (0 conflicting)
    The following 20 package(s) will be affected (of 0 checked):

    Installed packages to be REMOVED:
    oniguruma5-5.9.6_1

    New packages to be INSTALLED:
    oniguruma6: 6.4.0 [pfSense]
    pecl-ssh2-0: 0.13 [pfSense]
    libssh2: 1.8.0,3 [pfSense]

    Installed packages to be UPGRADED:
    strongswan: 5.5.2_1 -> 5.5.3 [pfSense]
    sqlite3: 3.19.3_1 -> 3.20.0_1 [pfSense]
    python27: 2.7.13_6 -> 2.7.13_7 [pfSense]
    php56-pfSense-module: 0.46 -> 0.48 [pfSense]
    php56-mbstring: 5.6.31 -> 5.6.31_1 [pfSense]
    pfSense-pkg-pfBlockerNG: 2.1.1_8 -> 2.1.1_10 [pfSense]
    pfSense-pkg-nut: 2.7.4_4 -> 2.7.4_5 [pfSense]
    pfSense-pkg-acme: 0.1.18 -> 0.1.19 [pfSense]
    pfSense-default-config: 2.4.0.b.20170724.1206 -> 2.4.0.r.20170904.0902 [pfSense-core]
    pfSense-base: 2.4.0.b.20170724.1206 -> 2.4.0.r.20170904.0902 [pfSense-core]
    pfSense-Status_Monitoring: 1.7.0_3 -> 1.7.1_3 [pfSense]
    pfSense: 2.4.0.b.20170724.1206 -> 2.4.0.r.20170903.1625 [pfSense]
    libidn2: 2.0.2 -> 2.0.3 [pfSense]
    ldns: 1.7.0 -> 1.7.0_1 [pfSense]
    curl: 7.54.1 -> 7.55.1 [pfSense]
    ca_root_nss: 3.31 -> 3.32 [pfSense]

    Number of packages to be removed: 1
    Number of packages to be installed: 3
    Number of packages to be upgraded: 16

    The operation will free 2 MiB.
    Upgrade is complete.  Rebooting in 10 seconds.

    Broadcast Message from admin@gandalf
            (/dev/pts/0) at 17:33 BST…

    Upgrade is complete.  Rebooting in 10 seconds.

    Locking package pfSense-kernel-pfSense...
    Locking pfSense-kernel-pfSense-2.4.0.r.20170904.0902

    And then it reboots...
    And I'm still on 2.4.0.b.20170724.1206

    Any ideas?



  • Try https://forum.pfsense.org/index.php?topic=135582.msg742380#msg742380

    If it doesn't work backup and reinstall.



  • That did the trick, thanks!


Log in to reply