No authentification page when I connect to the wi-fi



  • Hi guys,

    First, I'm sorry for my bad english !
    I just installed a PfSense which is connected to an access point and my router. My biggest problem is : When I connect to the Wifi, I have no authentification page showing up (tried on various computers, browsers and even on my smartphone). If I type the address in my devices : http://192.168.151.2:8002/index.php?zone=gsb_visiteurs, it shows the authentification page and I can log in.
    It then shows that I have 1 (or 2 when I connected 2 devices) active session in my admin interface. So I guess my captive portal is working fine but I have no clue why my authentification page won't show up instantly. I've tried to put the previous URL address as the "Pre-authentication redirect URL" and tried to put http://google.com as well just to see. None of them worked. On my computer, whenever I'm connected to the wifi, my DNS is the correct one, same as in Pfsense and my IP is good as well and whenever I manage to log myself in, it works fine but I cannot give this address to whoever is trying to access the wifi ^^ .
    Could anyone help me please ? I can answer other questions about my configuration if you have some !

    Thanks,  :)
    Louise



  • Take a look at this page : https://doc.pfsense.org/index.php/Captive_Portal_Troubleshooting

    Important to know : ALL OS'es today are "captive portal minded" : when you connect to Wifi network that uses a captive portal, it will (the login page) be brought up.

    "Pre-authentication redirect URL" and tried to put http://google.com

    Don't do that.
    Pre-auth page usage is something completely different.

    edit : https://forum.pfsense.org/index.php?topic=136370.0



  • First things first.

    Does the internet work if you turn off the captive portal? If not, check the rules on that interface.