IGMP woes



  • Today I moved to pfSense 2.4-RC.

    Every went fine except for the IGMP proxy.
    In contrast to what is mentioned in https://redmine.pfsense.org/issues/6099 IGMP is not working, at least not on vlan interfaces.
    Looking at the output of the IGMP debug log it shows the VIF index as 0x000000 always.

    In 2.3.4-1 I played around with different IGMPproxy deamons until I found one that actually (sort of) worked.
    That one showed the same interface as OutVifs: 0x00000002

    Route activate request from 213.75.167.58 to 224.3.2.6
    No table entry for 224.3.2.6 [From: 213.75.167.58]. Inserting route.
    No existing route for 224.3.2.6. Create new.
    No routes in table. Insert at beginning.
    Inserted route table entry for 224.3.2.6 on VIF #-1
    No downstream listeners for group 224.3.2.6. No join sent.

    Current routing table (Insert Route):
    –---------------------------------------------------
    #0: Src: 0.0.0.0, Dst: 224.3.2.6, Age:2, St: I, OutVifs: 0x00000000
    –---------------------------------------------------

    Current routing table (Activate Route):

    #0: Src: 213.75.167.58, Dst: 224.3.2.6, Age:2, St: A, OutVifs: 0x00000000
    –---------------------------------------------------
    Route activate request from 213.75.167.58 to 224.3.2.6

    Current routing table (Activate Route):

    #0: Src: 213.75.167.58, Dst: 224.3.2.6, Age:2, St: A, OutVifs: 0x00000000
    –---------------------------------------------------
    Route activate request from 213.75.167.58 to 224.3.2.6

    One other thing is that only OpenVPN client interfaces are in the config as disabled interface but OpenVPN server interfaces are not in the config.

    ##–----------------------------------------------------

    Enable Quickleave mode (Sends Leave instantly)

    ##------------------------------------------------------
    quickleave
    phyint igb3_vlan10 downstream ratelimit 0 threshold 1
    altnet 192.168.1.0/24

    phyint igb1_vlan4 upstream ratelimit 0 threshold 1
    altnet 10.58.240.0/20
    altnet 213.75.0.0/16
    altnet 224.0.0.0/4

    phyint pppoe1 disabled
    phyint igb2 disabled
    phyint igb0 disabled
    phyint ovpnc5 disabled  << OpenVPN client interface
    phyint igb3_vlan20 disabled

    I would expect

    ##–----------------------------------------------------

    Enable Quickleave mode (Sends Leave instantly)

    ##------------------------------------------------------
    quickleave
    phyint igb3_vlan10 downstream ratelimit 0 threshold 1
    altnet 192.168.1.0/24

    phyint igb1_vlan4 upstream ratelimit 0 threshold 1
    altnet 10.58.240.0/20
    altnet 213.75.0.0/16
    altnet 224.0.0.0/4

    phyint pppoe1 disabled
    phyint igb2 disabled
    phyint igb0 disabled
    phyint ovpns1 disabled  << OpenVPN server interfaces
    phyint ovpns2 disabled
    phyint ovpns3 disabled
    phyint ovpns4 disabled
    phyint ovpnc5 disabled  << OpenVPN client interface
    phyint igb3_vlan20 disabled


Log in to reply