Unable to View CAMS Internally

  • Hello Everyone!  I am totally new to PFSENSE –  Moving from Netgear Router to pfsense via an old PC- looking to take advantage of web monitoring for Kids.

    So here is my problem.  I have a DDNS setup, I have the port forwarding setup and I am able to view the cameras from any external point.  I have my existing Netgear router setup as an access point.  using the same app (IP Cam Viewer) I am unable to view the cams internally.

    Any suggestions?

    I seems like it is an internal DNS issue, but I don't have a local DNS running.  When the netgear was in router mode, I am able to view camera via using the DDNS address internally and externally.

  • LAYER 8 Global Moderator

    "but I don't have a local DNS running."

    So pfsense is not running dns, be it forwarder or resolver and all your clients use some external dns?

    You have 2 options setup an host override so your local clients asking pfsense for dns know that something.whatever.tld the fqdn your using for your camera points to internal IP of the camera.

    Other is NAT reflection that you would have to tell pfsense to do.

    On a side note you do understand that pretty much all cameras are very bad at security and opening up to the public internet is BAD.. And to be honest they should be isolated from the rest of your network via vlan or complete different physical network.  If you want to view them from outside you should vpn into your network.

  • Hi Johnpoz, thanks for replying back!  I have Pfsense doing everything  that my netgear router was doing.  I tried the reflection and it still did not work.

    I have the IP CAM APP configured with via hostname.com with port XXXX along with the ID and password  < – Works from Internet  / Does not Work internally

    The cams all have static IPs with NAT Port forwarding.

    I understand what you saying about the CAMs about being exposed to the Internet.  I am planning on setting up a VPN later on after I have everything working.

  • LAYER 8 Global Moderator

    Well if your clients are pointing to pfsense for their dns, and then pfsense forwards or resolves.  Then just setup a host override so that hostname.com points to your IP of cam you want to access.

Log in to reply