Ayuda portal cautivo(SOLUCIONADO)



  • Buenas tardes a toda la comunidad tengo un problema con mi portal cautivo y quiero que me orienten por favor

    les explico, tengo un portal cautivo  para un hotel que es lo que realice con este portal obviamente le entregamos a los clientes un usuario con una clave para cada habitación un un limite de conexiones dependiendo de la habitación que se les asigne el problema es el siguiente muchos de los clientes no logran logear o simplemente no los redirecciona a la pagina de autentificacion o inclusive algunos logran acceder pero no pasan a google que fue la pagina que establecí una vez se hayan registrado, el otro problema que tengo son los iphones esos tlf siempre tienen problemas para autentificar por el portal cautivo y debo estar agregandolos por direccion mac para que puedan acceder

    saludos.!

    tengo la ultima version del PFsense con virtual box espero me ayuden o orienten con mi problema :'(



  • ¿google por https?, nunca va a pasar el portal algo por https, ahora los equipos nuevos detectan que puede haber un portal, no deberías tener mucho problema con los celulares.

    ¿Qué conexión tienen los AP?, ¿que ping tienen al pfsense?

    Por alguna razón nunca me ha gustado virtualizar el pfsense, siento que el firewall/router debe ser dedicado.



  • gracias por contestar amigo, ok mira esta conectado de la siguiente manera

    tengo internet satelital por movistar osea dedicado a un router cisco EA2700 este se dirige al switch de los clientes donde estan conectadas todos los APs de los pisos que son APs ubiquiti

    otra cosa me dices que es mejor instalar de lleno el Pfsense en la pc y sacar del medio al virtual box?



  • Buenos días, exactamente eso dice, si tenes pleno conocimiento en virtualizacion funciona bien el pf, en mi opinión también es mejor dedicar un equipo al firewall, te vas a topar con menos problemas y mejores soluciones. Es como todo, sobre gustos no hay nada escrito pero en la practica en lo personal me ha funcionado de maravillas dedicarle como dice zac el pf sobre la maquina en si.
    Publica si quieres la configuración del portal para poder ver si te podemos ayudar en eso, tal ves sea una mala configuración.



  • Esta configurado de la siguiente manera

    WAN: 192.168.1.1/24 - DHCP - este recibe el ip directamente del router cisco debido que si coloco directamente la ip fija de movistar no funciona el puente y la lan nunca agarra internet

    LAN : 192.168.0.1/24

    Idle timeout (Minutes) 5 mins

    Pre-authentication redirect URL : $portal_redirurl$

    After authentication Redirection URL : http://google.com

    Authentication method : RADIUS Authentication

    RADIUS protocol : PAP

    Primary RADIUS server : 192.168.0.1  Port: 1812 y el sharesecret 123456

    RADIUS : Send RADIUS accounting packets to the primary RADIUS server. port 1813

    RADIUS MAC Authentication : si

    RADIUS NAS IP Attribute : 192.168.0.1

    Session timeout : si

    MAC address format : default

    en system esta lo siguiente

    webConfigurator : http

    WebGUI Login Autocomplete : si

    Enable : X Enable DHCP server on LAN interface

    Subnet 192.168.0.0
    Subnet mask 255.255.255.0
    Available range 192.168.0.1 - 192.168.0.254
    Range
    192.168.0.3
    From

    192.168.0.254
    To

    configuracion del freeradius

    interfacez

    Interface IP Address                   Port Interface    Type IP Version Description
    192.168.0.1                           1812 auth    ipaddr

    192.168.0.1                           1813 acct         ipaddr

    192.168.0.1                           1816 status        ipaddr

    NAS/CLIENT

    Client IP Address Client IP Version Client Shortname Client Protocol Client Type Require Message Authenticator Max Connections
    192.168.0.1               ipaddr                 playa                 udp          other                             no                           16

    esas son las configuraciones que tengo hechas si me salte algo porfavor diganme ya que soy un poco nuevo en este tema de los portales cautivos saludos



  • ¿Los AP que modelo son?, ¿están en modo puente?



  • Bueno chicos muchas gracias por los consejo resolví gran parte de mi problema solo me quedo 1 unos cavos sueltos que debo ver como solucionarlos gracias de verdad.!