OpenVPN/Boot hang



  • Installed 2.4 yesterday, working fine. Was playing round with OpenVPN - trying to add a client instance so I could connect to ProtonVPN servers. I was unsuccessful at this, with the OPenVPN logs saying:

    neither stdin nor stderr are a tty device and you have neither a controlling tty nor systemd - can't ask for 'Enter Auth Password:'. If you used –daemon, you need to use --askpass to make passphrase-protected keys work, and you can not use --auth-nocache

    Now that is an issue (if anyone has any tips on how to fix that'd also be appreciated) that I left until today to fix.

    This morning, logged onto pfSense and saw there was a 2.4 update, did the updated… waited, no internet, wait some more still no internet. power cycled the computer, nothing came back online. So turned it off, attached the monitor and keyboard again (as I don't have IPMI on this board), rebooted.

    and the boot process was hanging at this point

    ...
    Configuring LAN interface....done.
    Configuring CARP settings....done.
    Syncing OpenVPN settings...Enter Auth Password:

    and it was sat there waiting for an input. I pressed enter, and it just continued and booted absolutely fine.

    However this must be a bug? an incorrectly configured OpenVPN instance shouldn't cause the boot process to hang, and require hooking up a monitor and keyboard again to de-bug?

    [EDIT] I have now played around and fixed my OpenVPN client settings - hence connected to ProtonVPN servers, and therefore the boot happens fine now. However I still think the fact an improperly configured OpenVPN prevents a boot should be considered a bug?



  • Hi,

    Thank you for reporting this bug. I actually have the exact same issue after I've setup ProtonVPN.

    Could you share your workaround to establish the VPN connection?

    Thank you in advance,
    Fred



  • Configure "User Authentication Settings" user+pass of the openvpn client config.?


Log in to reply