PfSense 2.4.0-RC - No Packages Installed or Available? No AutoConfigBackup?



  • Currently on the latest version of Pfsense 2.4.0-RC,

    Version 2.4.0-RC (amd64)
    built on Fri Sep 08 20:44:08 CDT 2017
    FreeBSD 11.0-RELEASE-p12

    The system is on the latest version.

    Everything is working, Internet is active, so no issue accessing the internet…

    When I go System>Package Manager>Installed Packages,  ( which I had installed a few under 2.3.4) it shows 'no packages installed'.

    Similarly, System>Package Manager>Available Packages shows no packages either (see screenshots ).

    In addition, I have the AutoConfigBackup feature enabled; however, the system cannot communicate with the autoconfig server and save the configuration file( see screenshot).

    This issue started after an attempt to "save" changes, it looks like something was corrupted in the process. Also, I've had this happened before after updating to the latest 2.4RC. I fixed this by re-installing pfsense 2.3.4…so that's an avenue, however, I wonder if anyone has had this issue as well.

    I ran the pkg update -f

    and the output is this:


    Updating pfSense-core repository catalogue…
    pkg: Repository pfSense-core load error: access repo file(/var/db/pkg/repo-pfSense-core.sqlite) failed: No such file or directory
    pkg: https://beta.pfsense.org/packages/pfSense_devel_amd64-core/meta.txz: No address record
    repository pfSense-core has no meta file, using default settings
    pkg: https://beta.pfsense.org/packages/pfSense_devel_amd64-core/packagesite.txz: No address record
    Unable to update repository pfSense-core
    Updating pfSense repository catalogue...
    pkg: Repository pfSense load error: access repo file(/var/db/pkg/repo-pfSense.sqlite) failed: No such file or directory
    pkg: https://beta.pfsense.org/packages/pfSense_devel_amd64-pfSense_devel/meta.txz: No address record
    repository pfSense has no meta file, using default settings
    pkg: https://beta.pfsense.org/packages/pfSense_devel_amd64-pfSense_devel/packagesite.txz: No address record
    Unable to update repository pfSense
    Error updating repositories!
    **********

    Hope someone has seen this before.

    ![Screen Shot 2017-09-09 at 11.57.14 AM.png](/public/imported_attachments/1/Screen Shot 2017-09-09 at 11.57.14 AM.png)
    ![Screen Shot 2017-09-09 at 11.57.14 AM.png_thumb](/public/imported_attachments/1/Screen Shot 2017-09-09 at 11.57.14 AM.png_thumb)
    ![Screen Shot 2017-09-09 at 11.57.26 AM.png](/public/imported_attachments/1/Screen Shot 2017-09-09 at 11.57.26 AM.png)
    ![Screen Shot 2017-09-09 at 11.57.26 AM.png_thumb](/public/imported_attachments/1/Screen Shot 2017-09-09 at 11.57.26 AM.png_thumb)
    ![Screen Shot 2017-09-09 at 11.57.43 AM.png](/public/imported_attachments/1/Screen Shot 2017-09-09 at 11.57.43 AM.png)
    ![Screen Shot 2017-09-09 at 11.57.43 AM.png_thumb](/public/imported_attachments/1/Screen Shot 2017-09-09 at 11.57.43 AM.png_thumb)
    ![Screen Shot 2017-09-09 at 12.06.15 PM.png](/public/imported_attachments/1/Screen Shot 2017-09-09 at 12.06.15 PM.png)
    ![Screen Shot 2017-09-09 at 12.06.15 PM.png_thumb](/public/imported_attachments/1/Screen Shot 2017-09-09 at 12.06.15 PM.png_thumb)



  • Do you have a working dns server configured? Try setting 8.8.8.8 in system/generalsettings at dns.?



  • Yes, indeed, I have 4 DNS servers being ping simultaneously (not Google, they are just as bad tracking people), besides accessing the internet is not the issue if it was a DNS problem…I just don't have access to installed packages ( which is local to my pfSense) or available packages. I believe that to be a bug/something go corrupted in the savings process...it has happened to me 2X in 48 hrs...after going to 2.4 from 2.3.4... Thanks for the reply. I just did a clean reinstall of the system 2.3.4, and updated to 2.4RC...problem resolved. I'll see if this time it will stick.



  • "No address record" sounds a lot like a dns issue..
    but okay if its resolved for now, i guess there is little more to check a.t.m. what might have been the problem..



  • I had a similar experience upgrading from 2.3.4-p1 (pfBlockerNG and Suricata) to 2.4-RC. Package Manager did not show either available or installed packages. Missing pfBlockerNG rules generated error messages. Report was uploaded(?) to devs. Reinstalled 2.3.4 then upgraded to 2.3.4-p1. Reinstalled both packages.

    I'll try a fresh install with official release.