[SOLVED] apu2 internal TTL com port

  • Rebel Alliance Developer Netgate

    "garbage" makes me think it's sending at a different serial speed, whatever it is. Doesn't sound like anything that pfSense or FreeBSD would be doing though.

  • from time to time i see valid serial output but then it comes along with lot of garbage characters non stop, i tried the default baud rate of 115200 as well as all possible baud rates and its same except on other baud rates its total garbage, atleast on 115200 i see some of the pfsense output but the garbage is so much that it comes in bits and pieces.

  • Netgate Administrator

    A bad connection or interference on the cable can appear like that. Is the cable particularly long?


  • no its hardly 15cm and plus its happening on my adapter and apu2 as well as a different one in a client location.

  • Netgate Administrator

    Do you see that even when the console has not been switched to it?


  • yes but only when i press enter then all the garbage starts non stop, on a fresh boot when i connect doesnt display anything.

  • Netgate Administrator

    Hmm, sure sounds like something else is using the port. Just because the output is not ASCII does not mean it's garbage though, it may be some other format.

    Are you sure you haven't configured anything else on that port? Do you see that output even if pfSense it not booted?

    Try looking at the raw serial output rather than using a terminal emulator. That will rely on the port settings being correct.


  • when pfsense is not booted its blank coz the apu2 sends its bios menu only to the com1 which is the serial port, i have nothing else configured just a basic pfsense firewall with mostly everything default.

    i dont understand what do u mean by "Try looking at the raw serial output rather than using a terminal emulator. That will rely on the port settings being correct."

  • Netgate Administrator

    Ok, and hitting enter at that point does not start a stream of unreadable characters?

    That implies it's something being loaded by pfSense rather than debug output from the CPU or whatever.

    Are you sure you don't have say lcdproc or nut loaded?

    You are looking at the serial output with a terminal emulator that tries to interpret the data as characters or instructions to move the cursor etc but not all serial data is that.

    Try running on the connected device, for example:

    cat /dev/(your usb serial port) > /tmp/serial_output

    Then open that file in a hex editor. Since you can;t set the port speed it replies on whatever the port settings are already set to which must be correct to see meaningful data.

    Moving this to hardware since it's not 2.4 related.


  • no i dont have lcdproc or nut loaded, give me a few days as i have ordered a few more usb to uart adapters so once they arrive can attach those and test as well and report back as well as pcengines ppl are also testing it on their end to see if its debug info or no

  • Netgate Administrator

    I only suggested debug output there because the ALIX had this diagram available which is labelled debug so it seems to be something they might have done previously. A lot of speculation there!
    However if it were I might expect to see it whether or not pfSense loaded.


  • pcengines ppl just tested it using the same usb to ttl adapter and they send me a screenshot of it working and displaying properly so now im wondering if my tera term app is faulty or no so trying with putty

  • i tried with putty and its still same so lets just wait for the other adapter to come then ill report back

  • You wrote, "apu and older alix boards", which of them do you have here in that case!?
    Differences between Alix and APU

    Must be set up at three locations;

    • Putty or TerraTerm console program
    • Board BIOS for the COM port
    • pfSense directly

    then it will be often looking like the other one (com or serial port)
    Also on the other side it can surely be that the chip from the USB to Serial Adapter will not be supported due to
    whatever a circumstance. Be sure that you will be not led into a trap searching something you could not fix!

    If you are using an APU2Cx board you may be happy with that equipment here, it is working out of the box!
    As said both are working together with pfSense and verion 2.3.x & version 2.4 for me.
    APU2C4 serial to USB combo
    USB to RS232 cable

    And please make sure that you are using a null modem cable and not another serial cable!
    PC Engines HowTow collection

    If nothing helps you out here, but you will have the need for another console port you may have a look over that piece
    of hardware. AirConsole

  • AirConsole is nice, use it for years already. But it's basically a serial to USB converter with Ethernet extender. Doesn't change a thing on displaying the data, only extends the path.

  • ok finally got it working, the reason for garbage was along with the tx and rx line gnd also needs to be connected and my gnd pin on the adapter had a loose solder joint so gnd pin wasnt making contact, on the new adapter connected it and serial console started showing on com2 without issues, thanks for all the help

  • Netgate Administrator

    Ah, yup that'll do it!  :D


  • Meanwhile I found why my APU1 doesn't show uart1.
    That's an old beta board with an even older firmware. I bet if I'd update it…  ::)

    Good to hear that you got your problem solved! Productivity of this forum is quite amazing.

  • The nice thing about the APU series is that the GPIO driver written for the APU1 works with the newer APU2 and APU3. They used the same exact Nuvoton chip so I really appreciate the small things like that. Their Alix case with 3 LAN works with the newer APU as well.

    I just built a Zoneminder server based on the APU3 with 4Gig RAM and I got the PCIe slot option for a 2 port POE card, the Startech ST2000PEXPSE
    The slot is horizontal like the Soekris was.
    Zoneminder is hammering it -but it is not running that hot. It was just an experiment to see if the APU has other usage cases besides router.
    I have 3 now stacked.
    I really like coreboot too.. Really feels like an industrial setup.

  • Banned


    Meanwhile I found why my APU1 doesn't show uart1.
    That's an old beta board with an even older firmware. I bet if I'd update it…  ::)

    You can now update the BIOS from pfSense.

    pkg install flashrom
    flashrom -w apu??????.rom -p internal

  • Thanks Dok
    I found you must pass the programmer thru:

    flashrom --programmer internal -w /apu/apu2_v4.6.0.rom

  • Thanks Dok and FranciscoFranco, worked perfectly.

  • @doktornotor

    Any ideas why I'm getting a board mismatch error:

    Calibrating delay loop… delay loop is unreliable, trying to continue OK.
    coreboot table found at 0xdffae000.
    Found chipset "AMD FCH".
    Enabling flash write... OK.
    Found Winbond flash chip "W25Q64.V" (8192 kB, SPI) mapped at physical address 0x00000000ff800000.
    This coreboot image (PC Engines:PC Engines apu2) does not appear to
    be correct for the detected mainboard (PC Engines:PCEngines apu2).
    Aborting. You can override this with -p internal:boardmismatch=force.

    As you can see in the logs, they're the same exact board so I'm not sure why there's a mismatch?

    EDIT: Nevermind, I already figured it out. It seems to be caused by the space between PC and Engines so forcing it fixed the problem.

Log in to reply