Port forward, 2 wan, e foraztura ad uscire sulla stessa WAN



  • Buongiorno a tutti,

    sto incontrando questo problema:

    il FW ha 2 WAN in load balance e failover(impostate come da guida presa da pfsenseitaly.com)

    una macchina nella rete interna, windows serv 2008, deve rispondere a delle chiamate dall'esterno sul IIS con https attivo sulla porta 443
    Per questa esigenza ho impostato una regola di port forward, che ha creato in automatico nelle rules una regola,
    tale per cui chiamando l'indirizzo IP della WAN1 del mio FW riblata correttamente sul server interno
    e fin qui tutto bene…

    il problema consiste nel fatto che il server 2008, con questo applicativo, a sua volta, fa una chiamata verso un server esterno,
    e a volte perde dei pacchetti per strada e non porta a termine le operazioni che deve svolgere.
    immagino che tal problema sia dovuto al bilanciamento sulla WAN1 e 2... nel senso che magari parte un'operazione sulla WAN1 e poi viene dirottata in bilanciamento sulla WAN2

    La domanda è:
    come posso "forzare" una macchina della LAN ad uscire sempre ed indistintamente sulla medesima WAN? baypassando naturalmente tutte le regole di balance e fail over...



  • Ciao,
    in Roules > Lan crea una regola che ha come source il tuo server, poi imposta eventuali altri filtri per discriminare il traffico che vuoi far uscire da una sola wan
    In advanced options > gateway imposta il gateway che vuoi usare o meglio ancora un gateway grou che facci afault tollerance
    Creare 2 gateway group in modo che imposti un gruppo con Wan1 con tyer 1 e wan2 con tyer 2 ed un gruppo con l'opposto.
    Questo fa si che se un gateway è down, il traffico in uscita passa al gateway con tyer 2

    Ciao Fabio



  • Grazie mille per il tuo prezioso consiglio,

    ho creato la regola e messa in prima posizione nella LAN

    I gruppi con il tier erano già impostati essendo il FW impostato con il failover, ma ho preferito impostare il GW di uscita sulla WAN1 sempre, anche se casca la linea;
    questo perchè, ricevo dall'esterno sull'IP del GW, quindi se fosse down, non avrei comunque nessuna chiamata dall'esterno.

    Per ora vedo che funziona tutto regolarmente.

    Grazie ancora