Scheinbar ARP Problem



  • Hi,
    mir ist aufgefallen, das meine Clients über die PFS ins Internet geblockt werden. Bisher hatte ich die PFS einfach neugestartet, dann ging es eine gewisse Zeit wieder, ich schätze mal so 1-2h, dann wurden aufeinmal wieder alle geblockt. In den Logs konnte ich nicht wirklich was sehen. Nun bin ich auf den ARP Cache getoßen und habe von Hand einfach mal die Clients gelöscht udn siehe da, es lief wieder. Ich habe die Einstellungen im DHCP und DNS Resolver geprüft, aber nichts wirklich falsches gefunden. Nun bin ich etwas verunsichert und brauche nen Rat ob das so überhaupt korrekt konfiguriert ist. Das Netz
    <-Internet –> Router 192.168.1.x -> PFS (WAN) 192.168.0.x DHCP / DNS Resolver und Reservierungen -> Clients.

    Optionen

    • Interfaces LAN / WAN jeweils Block private networks und bogon networks = deaktiviert

    • DHCP - Static ARP entries = deaktiviert (das letzte Mal nach Aktivierung, wurden die Clients geblockt)

    • DHCP keine MAC Kontrolle etc.

    • DHCP static Mappings und dort di MACs kontrolliert = ok

    • DNS Resolver - Network Interfaces = All

    • DNS Resolver - Outgoing Interfaces = WAN

    • DNS Resolver Transparent

    • DNS Resolver DNSSEC = aktiviert

    • DNS Resolver DHCP Registration = aktiviert

    • DNS Resolver Static DHCP = aktiviert

    Das im Groben - was mir noch auffiel - nachdem es zum blocken der Clients kam hatte ich im ARP Cache der PFS geshen, dass die MAC nicht mit der vom Client übereinstimmt und auch von mir keinem anderen zugeordnet werden konnte.

    Hoffe jemand kann helfen.
    Danke



  • Hallo,

    läuft vielleicht ein zweiter DHCP Server im Netz?



  • Hi,
    ja der des Routers, aber nur auf 192.168.1.x und merkwürdig ist, dass wenn kein hoher Internettraffic über die PFS läuft, alles stabil ist. Erst wenn ich die Leitung z.B. über 1-2h mal Auslaste, dann blockiert sie.

    edit1: so eben in der ARP Table nachgeshen: client01 hat die korrekte reservierte IP aber die MAC ist def. die falsche. ?!!
    edit2: führe ich nen arp ip-client1 aus so erhalte ich "kein eintrag"
    edit3: führe ich arp ip-client1 von einem 2. client aus, so erhalte ich die auch vom client unter ifconfig angezeigt  wird, aber aktuell nciht auf der pfs im table steht ?!?
    edit4: eben von einem weiteren Client kontrolliert, ebenfalls komplett falsche MAC in der Table der pfs
    edit5: eben eine alte Reservierung aus dem DHCP gelöscht, Dienst neugestartet und nun ist die Verbindung weg, wohl wegen der fehlerhaften ARP Table

    edit6: System Log shows - rp: <wrong mac="">attempts to modify permanent entry for <client1-ip>on em0
    edit7: in logs i see Unable to add forward map from client1 notimp <- what does this mean?

    edit8: eben im DHCP Log gesehen: dhcpleases kqueue error: unkown
    dhcpleases Could not deliver signal HUP to process because its pidfile (/var/run/unbound.pid) does not exist, No such process.
    dhcpleases /var/etc/hosts changed size from original!

    Ursache: ok ich denke ich weiß woran es liegt - die Clients sind virtuell unter Proxmox und dort ist die Firewall aktiv, war mir vorher nicht bewußt aber ist Testing, sodass dort mehrere Clients die selbe MAC erhalten bzw. als Verschleierung verteilt werden, aber das weiß ich auch noch nicht genau. Evtl. weiß hierzu jemand mehr und vor allem wie man das dann in PFS kontrolliert.</client1-ip></wrong>