FIXED! Unable to contact webgui:console can ping wan & lan but others csnt



  • Hello!
    This is probably off-topic but if I use console access I can ping wan and lan ip addresses but I can not ping the wan address and Firefox can not load webconfigurator.
    The box accessing console via usb cable has ether plugged into lan port directly (no switch).
    I have used 'sudo ip addr add 192.168.2.1 dev eth0' and 'sudo ip route add default via 192.168.2.1'
    Ping'ing from terminal to lan address works but not wan address. It used to work. The console shows both addresses correctly.
    Thx in advance.
    JC Magras

    FIX: change my client device ip address. I did a ping on lan address after invoking shell on pfsense box. The pfsense LAN address and client ip address were the same. The fact that this duped address situation worked is appalling. This dup address proves routing debugging tools are still needed.



  • Hi,
    @magrw2066:

    … I use console access I can ping wan .... addresses but I can not ping the wan address ....

    Can or can't ?

    @magrw2066:

    The box accessing console via usb cable has ether plugged into lan port directly (no switch).

    This might work but is considered a not done.
    Use a switch.
    If NIC's are not auto-MDX and you do not use a very special cross over cable, there will be no connection.

    @magrw2066:

    I have used 'sudo ip addr add 192.168.2.1 dev eth0' and 'sudo ip route add default via 192.168.2.1'
    Ping'ing from terminal to lan address works but not wan address. It used to work. The console shows both addresses correctly.

    Where ? On the PC ?
    The dhcp-client should be set to pick up a IP/DNS/Gateway.



  • @Gertjan:

    Hi,
    @magrw2066:

    … I use console access I can ping wan .... addresses but I can not ping the wan address ....

    Can or can't ?
    Ok my apologies for this unclarity.
    Console(aka /dev/ttyUSB0) can ping wan and lan addresses w/out problem.
    (Does raspberry pi linux flavors have screen?)
    But over Ethernet no route found to pfsense box

    @magrw2066:

    The box accessing console via usb cable has ether plugged into lan port directly (no switch).

    This might work but is considered a not done.
    Use a switch.
    If NIC's are not auto-MDX and you do not use a very special cross over cable, there will be no connection.
    Thank you for clarifying that but has usually worked.

    @magrw2066:

    I have used 'sudo ip addr add 192.168.2.1 dev eth0' and 'sudo ip route add default via 192.168.2.1'
    Ping'ing from terminal to lan address works but not wan address. It used to work. The console shows both addresses correctly.

    Where ? On the PC ?
    The dhcp-client should be set to pick up a IP/DNS/Gateway.

    This has been overridden for simplicity even if unrealistic




  • The images show … what you already described  :D
    This still stands : use a switch or that special network cable or buy one.

    edit : btw : I'll bet that when you use tcpdump on pfSense on the LAN port, you'll see NOTHING coming in …. because no "electrical" contact.



  • The trendnet 8 port gigabit greener switch did zero.
    Reading a similar post. 'ps ax|grep nginx' returns nothing!!!



  • You took option 8, and then

    ps ax| grep nginx
    

    like :

    Using username "admin".
    Authenticating with public key "rsa-key-20150201"
    Passphrase for key "rsa-key-20150201":
    *** Welcome to pfSense 2.3.4-RELEASE-p1 (amd64 full-install) on pfsense ***
    
     WAN (wan)       -> rl0        -> v4/DHCP4: 192.168.10.11/24
     LAN (lan)       -> fxp0       -> v4: 192.168.1.1/24
                                      v6: 2001:470:1f13:5c0:2::1/64
     PORTAL (opt1)   -> sis0       -> v4: 192.168.2.1/24
     HENETV6 (opt2)  -> gif0       -> v6: 2001:470:1f12:5c0::2/128
    
     0) Logout (SSH only)                  9) pfTop
     1) Assign Interfaces                 10) Filter Logs
     2) Set interface(s) IP address       11) Restart webConfigurator
     3) Reset webConfigurator password    12) PHP shell + pfSense tools
     4) Reset to factory defaults         13) Update from console
     5) Reboot system                     14) Disable Secure Shell (sshd)
     6) Halt system                       15) Restore recent configuration
     7) Ping host                         16) Restart PHP-FPM
     8) Shell
    
    Enter an option: 8
    
    [2.3.4-RELEASE][admin@pfsense.brit-hotel-fumel.net]/root: ps ax | grep nginx
    59113  -  Is      0:00.00 nginx: master process /usr/local/sbin/nginx -c /var/e
    59309  -  I       0:00.16 nginx: worker process (nginx)
    59386  -  I       0:02.17 nginx: worker process (nginx)
    60212  -  Is      0:00.01 nginx: master process /usr/local/sbin/nginx -c /var/e
    60287  -  I       0:00.01 nginx: worker process (nginx)
    60821  -  I       0:00.03 nginx: worker process (nginx)
    60865  -  I       0:00.03 nginx: worker process (nginx)
    60931  -  I       0:00.23 nginx: worker process (nginx)
    61000  -  I       0:00.05 nginx: worker process (nginx)
    61191  -  I       0:01.18 nginx: worker process (nginx)
    61366  -  Is      0:00.01 nginx: master process /usr/local/sbin/nginx -c /var/e
    61549  -  I       0:03.60 nginx: worker process (nginx)
    61819  -  I       0:06.54 nginx: worker process (nginx)
    61826  -  I       1:31.12 nginx: worker process (nginx)
    62171  -  I       0:07.92 nginx: worker process (nginx)
    62509  -  I       0:12.22 nginx: worker process (nginx)
    62980  -  I       0:21.17 nginx: worker process (nginx)
    67176  -  I       0:00.11 php-fpm: pool nginx (php-fpm)
    91352  0  S+      0:00.00 grep nginx
    [2.3.4-RELEASE][admin@pfsense.brit-hotel-fumel.net]/root:
    

    you had no output ?
    Thus : now GUI web server running ??



  • Ok it seems nginx IS running and 'netstat -l -p tcp-a -n|grep 80' confirms this.
    I had some mark values in my routing and tried ping's -m but that route is for tcp.
    Ping -r for ignoring routing did not work.

    Sincerely,
    JC Magras


Log in to reply