Unable to change channel from "auto"



  • I am trying to set up the wireless interface in my new mini-PC in order to use it as a wired/wireless router.
    I am in the Interfaces screen.
    I have saved what I thought were the proper settings and I get the common "A specific channel, not auto, must be selected for Access Point mode." error.
    However, I cannot select anything in channel other than Auto.
    I have set things as follows:
    Speed and Duplex autoselect mode 11b hostap
    Regulatory Domain:  FCC
    Country:  United States
    Location: Indoor
    Mode:  Access Point

    Under Common Wireless Configuration - Settings apply to all wireless networks on run0.
    There are two settings, Standard and Channel.  It is impossible to change them to anything but Auto, even after doing all the other settings above, entering an SSID, etc.
    Why is that, and how can I get around it?

    ifconfig has this to say:

    run0: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 2290
            ether [snip]
            nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect (autoselect <hostap>)
            status: no carrier
    run0_wlan1: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
            ether [snip]
            nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect <hostap>(autoselect <hostap>)
            status: no carrier
            ssid "" channel 1 (2412 MHz 11b)
            country US authmode OPEN privacy OFF txpower 0 scanvalid 60 wme

    I don't know why there are the two of them, is that normal?  Is there a text config file somewhere?  Is it possible to paste a working one here?</hostap></hostap></performnud,auto_linklocal></broadcast,simplex,multicast></hostap></performnud,auto_linklocal></broadcast,simplex,multicast>



  • I got past that point by choosing Infrastructure/BBS mode instead of Access Point and rebooting.
    Everything looks correct, except the interface still will not come up.  I'll post another thread about that later.




Log in to reply