Pfsense returns to default certificate after reboot.



  • Hello,
    Everything is in the title.
    My certificate is well installed on both pfsense of my cluster. It never happens on "primary" node, but it randomly happens on "backup" node.
    HTTPS returns on default certificate, so because of HSTS, I'm no longer able to access with FQDN, I need to access to webUI with IP address, and revert back to my certificate…
    ...until next time...  >:(  ???

    Thanks for any help !


  • Rebel Alliance Developer Netgate

    With a cluster, the certificates are shared between both nodes. If you import a cert for the secondary directly on the secondary it will be overwritten by the certs from the primary during the next config sync.

    You can do two things:

    1. Use a single certificate to cover both nodes (SANs include hostnames for primary, secondary, and a hostname for the CARP VIP for other purposes, or perhaps a wildcard cert) and then select this for use as the GUI cert on both nodes. This is simple with ACME and the way we usually recommend doing it.

    2. Import the primary and secondary GUI certs to the primary node, so they will be synchronized to both units. Then pick the certificate in the GUI settings after that.


Log in to reply