Problema con dos WAN



  • Hola a todos,
    mi problema es el siguiente, estoy usando pfSense versión 1.2-RC2 en una máquina con seis interfaces, dos de ellas configuradas como WAN y WAN2 con las ip's públicas y ambas ip's tienen el mismo gateway(no estoy seguro de que esto me afecte en algún sentido), puesto que se encuentran en la misma subred de mi ISP.
    Otras dos interfaces definidas como LAN2 y LAN3 las tengo conectadas a dos subredes, la 2.0 y la 4.0.
    Simplemente quiero que cada una de esas subredes tenga como gateway una IP pública distinta, es decir que la LAN2 tenga la salida a internet por la WAN y la LAN3 tenga salida a internet por la WAN2, pero pfSense siempre me redirige la salida a la WAN por defecto con lo cual tengo inutilizada la IP pública de la WAN2.

    ¿Alguien me puede ayudar con la configuración necesaria para realizar este tráfico?

    Un saludo y gracias por adelantado.



  • ¡Hola!

    Tienes que rellenar el campo gateway de las reglas de tu cortafuegos con las IPs de salida que quiera emplear, en lugar de dejarlas con *****.

    Saludos,

    Josep Pujadas



  • Eso mismo pensé yo,  pero en ese campo me sale un desplegable que me da a escoger entre :

    • default
    • <la ip="" del="" gateway="" de="" la="" wan="">- <la ip="" del="" gateway="" de="" la="" wan2="">El problema es que esa ip es la misma como he comentado y escoja la que escoja el tráfico sale por la WAN nunca por la WAN2

    Gracias.</la></la>



  • ¡Hola de nuevo!

    Si el cortafuegos trabaja en modo enrutador (lo habitual) cada interfase debe pertenecer a una subred distinta. En tu caso WAN y WAN2 pertenecen a la misma subred pública.

    La única solución que se me ocurre es que montes dos pfSense, aunque no me queda claro si eso puede ser un problema para tu topología de redes.

    Tampoco me queda claro si tienes tu el control sobre los equipos de conexión a Internet o es tu ISP quien los configura. Si pudieses variar la configuración de estos equipos yo haría que fuera éllos quienes tomasen la IP pública en su lado WAN y una de privada en su lado LAN, tal como se muestra en:

    http://www.bellera.cat/josep/pfsense/imatges/cas_estudi.jpg

    Saludos,

    Josep Pujadas



  • Buenas,

    He conseguido que nuestro ISP nos cambié la subred a la que pertenece una de las WAN de forma que tenga un gateway distinto a la otra, y ahora todo funciona correctamente.

    Un saludo, y gracias por tu ayuda.


Log in to reply