[SOLVED] Single User Shell launches every time



  • 2.4.0-RC 10/8/2017

    I was troubleshooting a pkg update issue and booted into Single User Mode once.  Ever since then, I get a Single User shell opening every boot.  I've tried everything from the boot Menu:  Hitting "1" or "Enter" for Multi User Mode doesn't work.

    Screenshot shows the screen I get.  I have to hit Enter then type "exit" before the system boots up into Multi-User Mode.


  • Rebel Alliance Developer Netgate

    How did you boot into single user mode?

    If you used the reboot menu option, run this command at a shell prompt after booting up pfSense all the way:

    nextboot -D
    

    Also you should be on the snapshot from the 9th, see https://forum.pfsense.org/index.php?topic=137682.msg753525#msg753525 and you'll probably have to force everything to upgrade, a reinstall may be safer.



  • Thanks, nextboot -D cleared up the single user shell auto-loading.

    The 10/8 snapshot's been giving me hell, so I had to reinstall with the 10/9 snapshot.  Successfully upgraded to 2.4.0-RELEASE after that.