Problème de redirection (portail captif)



  • Bonjour à toutes et à tous,

    Étant bloqué depuis plusieurs jours sans trouver la solution à mon soucis je m'en remet à vous pour vous demander un petit coup de pouce. :-[
    Je vous explique un peu le contexte :

    Je veux mettre en place un portail captif pour le réseau public de mon entreprise. Pour se faire, j'utilise donc PfSense. Le portail captif est mi en place et fonctionne. J'ai tout de même un petit soucis.

    • Lorsqu'un utilisateur se connecte à la borne wifi et qu'il va sur le net, dans le navigateur s'il tape une adresse IP (n'importe laquelle même une qui ne correspond à rien) il est redirigé vers le portail captif (ce qui est normal). Cependant lorsqu'il tape un domaine (par exemple www.google.fr) ça ne le redirige pas vers le portail captif mais lui dit simplement qu'il n'a pas internet. J'essaye de résoudre ce soucis pour que quand l'utilisateur tape un nom de domaine il soit redirigé vers le portail captif.

    Petites précisions :

    • PF sense (carte WAN) ping bien sans aucun soucis les noms de domaines
    • L'ip du serveur DNS qui est donné en DHCP sur les machines clientes est l'ip de la carte LAN de mon PfSense
    • Bien naturellement une fois l'auth passée du portail captif le client à accès au réseau et au géant internet

    Si vous avez déjà eu le cas où une idée du pourquoi du comment je vous en serait très reconnaissant.

    Merci d'avance  ;D



  • Rebonjour,

    J'avais fais une recherche sur le forum avant mais j'avais pas vu un post qui répond à ma question :

    https://forum.pfsense.org/index.php?topic=137608.msg753774#msg753774

    Désolé du dérangement je sais pas comment faire pour archiver ou supprimer mon post, si un modérateur voit ça il peut le supprimer ya pas de soucis.

    Mon problème était que pour mes tests j'essaye toujours de me connecte à www.google.fr pour voir si la redirection se fait mais le bon google est en https, après un test sur un site en http ya aucun soucis de fonctionnement.

    Encore désolé et bonne journée/weekend à tous



  • :)
    Comme quoi, Google est loin d'être aussi bien que ce que ça donne l'impression d'être  :P



  • En fait, la recherche sur le forum devrait toujours être un préalable.

    Pour peu qu'un problème soit bien défini … et que les mécanismes, ainsi que leur conséquences, soient bien compris (voire précisés par un intervenant).

    En l'espèce, quand on va sur Google, on ne s'aperçoit pas, instantanément, que l'on passe en HTTPS, ... donc le portail ne peut pas fonctionner !
    Comme la tendance est aux sites HTTPS, il va être difficile de faire fonctionner des portails captifs ...

    Il est toujours utile de bien comprendre un mécanisme (un portail capif), c'est à dire comment il fonctionne.
    Et il est aussi essentiel de connaitre les conséquences sous-jacentes ...