Pfblocker -> Click to view these packets in Alerts tab ?



  • in 2.3.4 and in the new version of 2.4 pfblocker doesn´t show the blocked packets if i click on the widget link.

    of course "all alerts" can be listed if i click directly on the alerts tab, but not the specific counted ones over the widget tab from pfblocker.

    Even if i click on "Apply filter" nothing is shown.

    see my screenshot for more details. or am i wrong ?






  • The filter is applied on the Firewall circular log file, so as new blocks occur older entries vanish.
    You can increase the size of the log files to display more alerts. (Status / System / Logs Settings)

    The widget track the log file and gather statistics over time.



  • thx but, I can not quite follow you! :-(
    Can´t find the menus you told me :-(
    Where do i have to change what?
    I´m using 2.4 stable release!

    see my screenshots!





  • Moderator

    The pfBlockerNG Alerts tab collects the logs from the pfSense Firewall Log.

    In pfSense > Status > System Logs > Settings:

    You can increase the "Log file size" so that more data can be retrieved in the Alerts Tab… I would also recommend unchecking "Log packets matched from the default block rules" as that can fill your firewall.log.

    While there, check the "Where to show rule descriptions" and change that to "Display as column"



  • thx for your support.
    i have modified and saved the settings you told me. Do i have to restart any service to apply the changes?

    thx4all


  • Moderator

    Not really… You could Force Reload - All for good measure tho... That will reload all the Alias/Groups at once...



  • ok, i did a force reload in pfblocker for safety reasons!

    I'm curious about what is changing now.  ;)

    thank you!!



  • So I did also a restart of the firewall and waited until I got a new entry in the pfblocker widget.
    I clicked on this counter Link but again nothing. the result of the roles, listed in the role number field are not displayed even if i click on apply filter.
    the file size of the log files are now each increased to 10mb -> In bytes of course. so, that can´t be the problem.
    -> see the screenshots

    This function does not work :-(






  • There is a note under the settings :

    NOTE: Log sizes are changed the next time a log file is cleared or deleted. To immediately increase the size of the log files, first save the options to set the size, then clear all logs using the "Reset Log Files" option farther down this page. Be aware that increasing this value increases every log file size, so disk usage will increase significantly.



  • @RonpfS:

    There is a note under the settings :

    NOTE: Log sizes are changed the next time a log file is cleared or deleted. To immediately increase the size of the log files, first save the options to set the size, then clear all logs using the "Reset Log Files" option farther down this page. Be aware that increasing this value increases every log file size, so disk usage will increase significantly.

    After saving and reseting the logs, same problem again.
    Can anyone reproduce that?

    Thx



  • Am i the only one who has this problem ?  :(


  • Moderator

    @pfsense_user12123:

    Am i the only one who has this problem ?  :(

    Do you use Adv. In/Out rule settings?

    Maybe this issue:
        https://forum.pfsense.org/index.php?topic=99929.0


  • Moderator

    If you goto the pfSense firewall log, do you see these alerts?


Log in to reply