OpenVPN core error: crypto_alg: DSA: not found



  • Hi,

    Hopefully somebody can help me, I have tried setting up both IPSEC and OpenVPN on a VM, an old PC and now a dedicated Celeron J1900 PC with 4gb ram and 32gb SSD.

    With OpenVPN I followed the excellent guide at https://www.youtube.com/watch?v=xiy52Hn5bTc and got far further than with any other guide, however when I export the config file and import into OpenVPN Connect on my Android phone (I've tried on my OnePlus5 and Galaxy S5), I enter my username and password and then get the error message "OpenVPN core error: crypto_alg: DSA: not found"

    After some research it seemed to point to the encryption not being supported my my device(s). I'm using pfSense 2.4 and even selected no encryption but still get the very same error.

    If I tried to setup IPSEC I could get it to connect without any problem, but it wouldn't get an IP address and wouldn't tunnel any traffic.

    I've setup IPSEC on Cyberoam firewalls and have used OpenVPN on my DD-WRT router for many years without problem.

    I can't believe for a piece of software that's so popular and widely used that it could be this hard to setup, so I'm guessing that I must be missing something blatantly obvious but can't see what.

    If anyone has any thought or guidance it would be hugely appreciated.

    Regards,

    Robert.

    UPDATE: I've managed to get it working in the time since this post. I changed:
    Encryption Algorithm to: AES-256-CBC (256 bit key, 128 bit lock)
    and Auth digest algorithm to: SHA256 (256-bit)