Captive Portal was working then stoped.



  • Hi all,

    I am new to pfSense I was able to get the Captive Portal working and then about a month ago the redirect to the CP HTML page would not work. I have tried to do everything but reset to default settings on the pfSense box.  I am not sure on how to get my config and upload it here. Any help would be greatly appreciated.

    P.S. I have read this https://doc.pfsense.org/index.php/Captive_Portal_Troubleshooting#Captive_portal_not_redirecting, but it has not really helped me to find out why it was working and not it is not. :-\



  • What version ? Settings ? Rules ? Interfaces ? Your captive portal page or the built in one ? Authentication ?

    Be aware that "Portal doesn't work" is a rather known issue - and usually the issue is found quickly as soon as the administrator understood that his 'knowledge' of ground rules of networking actually broke the portal.

    It's impossible to send some over right now to check things for you  ;)

    Not new is that people don"t understand how to set up the AP's involved. Another factor to mess with.



  • PFsense 2.4.0

    I made my own HTML page with the required buttons

    <captiveportal><pf_als_wifi>PF_ALS_WIFI

    <zoneid>2</zoneid>
    <interface>lan</interface>
    <maxproc></maxproc>
    <timeout>480</timeout>
    <idletimeout>60</idletimeout>

    <auth_method>none</auth_method>
    <reauthenticateacct></reauthenticateacct>
    <httpsname></httpsname>
    <preauthurl></preauthurl>
    <blockedmacsurl></blockedmacsurl>
    <bwdefaultdn></bwdefaultdn>
    <bwdefaultup></bwdefaultup>
    <certref>59a5893427613</certref>
    <radius_protocol></radius_protocol>

    <radiusip></radiusip>
    <radiusip2></radiusip2>
    <radiusip3></radiusip3>
    <radiusip4></radiusip4>
    <radiusport></radiusport>
    <radiusport2></radiusport2>
    <radiusport3></radiusport3>
    <radiusport4></radiusport4>
    <radiusacctport></radiusacctport>
    <radiuskey></radiuskey>
    <radiuskey2></radiuskey2>
    <radiuskey3></radiuskey3>
    <radiuskey4></radiuskey4>
    <radiusvendor>default</radiusvendor>
    <radiussrcip_attribute>wan</radiussrcip_attribute>
    <radmac_format>default</radmac_format>
    <radiusnasid></radiusnasid>
    <page><rule><type>pass</type>
    <ipprotocol>inet</ipprotocol>

    <interface>lan</interface>
    <tracker>0100000101</tracker>
    <source>
    <network>lan</network>

    <destination><any></any></destination></rule>
    <rule><type>pass</type>
    <ipprotocol>inet6</ipprotocol>

    <interface>lan</interface>
    <tracker>0100000102</tracker>
    <source>
    <network>lan</network>

    <destination><any></any></destination></rule>
    <rule><tracker>1504021497</tracker>
    <type>pass</type>
    <interface>lan</interface>
    <ipprotocol>inet</ipprotocol>
    <tag></tag>
    <tagged></tagged>
    <max></max>
    <max-src-nodes></max-src-nodes>
    <max-src-conn></max-src-conn>
    <max-src-states></max-src-states>
    <statetimeout></statetimeout>
    <statetype></statetype>

    <source>
    <network>lan</network>

    <destination><network>wan</network></destination>

    <updated><time>1504021497</time>
    <username>admin@192.168.1.101</username></updated>
    <created><time>1504021497</time>
    <username>admin@192.168.1.101</username></created></rule>
    <rule><tracker>1506003351</tracker>
    <type>pass</type>
    <interface>lan</interface>
    <ipprotocol>inet</ipprotocol>
    <tag></tag>
    <tagged></tagged>
    <max></max>
    <max-src-nodes></max-src-nodes>
    <max-src-conn></max-src-conn>
    <max-src-states></max-src-states>
    <statetimeout></statetimeout>
    <statetype></statetype>

    <protocol>tcp</protocol>
    <source>

    <address>192.168.1.200</address>

    <destination><any></any></destination>

    <updated><time>1506003351</time>
    <username>admin@192.168.1.101</username></updated>
    <created><time>1506003351</time>
    <username>admin@192.168.1.101</username></created></rule>

    <nat><outbound><mode>automatic</mode></outbound></nat>

    <interfaces><wan><enable></enable>
    <if>re0</if>

    <alias-address></alias-address>
    <alias-subnet>32</alias-subnet>
    <spoofmac></spoofmac>
    <ipaddr>dhcp</ipaddr>
    <dhcphostname></dhcphostname>

    <adv_dhcp_pt_timeout></adv_dhcp_pt_timeout>
    <adv_dhcp_pt_retry></adv_dhcp_pt_retry>
    <adv_dhcp_pt_select_timeout></adv_dhcp_pt_select_timeout>
    <adv_dhcp_pt_reboot></adv_dhcp_pt_reboot>
    <adv_dhcp_pt_backoff_cutoff></adv_dhcp_pt_backoff_cutoff>
    <adv_dhcp_pt_initial_interval></adv_dhcp_pt_initial_interval>
    <adv_dhcp_pt_values>SavedCfg</adv_dhcp_pt_values>
    <adv_dhcp_send_options></adv_dhcp_send_options>
    <adv_dhcp_request_options></adv_dhcp_request_options>
    <adv_dhcp_required_options></adv_dhcp_required_options>
    <adv_dhcp_option_modifiers></adv_dhcp_option_modifiers>
    <adv_dhcp_config_advanced></adv_dhcp_config_advanced>
    <adv_dhcp_config_file_override></adv_dhcp_config_file_override>
    <adv_dhcp_config_file_override_path></adv_dhcp_config_file_override_path>
    <ipaddrv6>dhcp6</ipaddrv6>

    <dhcp6-ia-pd-len>0</dhcp6-ia-pd-len></wan>
    <lan><enable></enable>
    <if>re1</if>
    <ipaddr>192.168.1.1</ipaddr>
    <subnet>24</subnet>
    <ipaddrv6>track6</ipaddrv6>
    <subnetv6>64</subnetv6>
    <media></media>
    <mediaopt></mediaopt>
    <track6-interface>wan</track6-interface>
    <track6-prefix-id>0</track6-prefix-id></lan></interfaces>
    <staticroutes></staticroutes>
    <dhcpd><lan><enable></enable>
    <range><from>192.168.1.2</from>
    <to>192.168.1.206</to></range>
    <failover_peerip></failover_peerip>
    <dhcpleaseinlocaltime></dhcpleaseinlocaltime>
    <defaultleasetime></defaultleasetime>
    <maxleasetime></maxleasetime>
    <netmask></netmask>
    <gateway></gateway>
    <domain></domain>
    <domainsearchlist></domainsearchlist>
    <ddnsdomain></ddnsdomain>
    <ddnsdomainprimary></ddnsdomainprimary>
    <ddnsdomainkeyname></ddnsdomainkeyname>
    <ddnsdomainkey></ddnsdomainkey>
    <mac_allow></mac_allow>
    <mac_deny></mac_deny>

    <ldap></ldap>

    <filename></filename>
    <filename32></filename32>
    <filename64></filename64>
    <rootpath></rootpath>

    <dnsserver>208.67.222.222</dnsserver>
    <dnsserver>208.67.222.220</dnsserver></lan></dhcpd>
    <dhcpdv6><lan><enable></enable>
    <range><from>::1000</from>
    <to>::2000</to></range>
    <ramode>assist</ramode>
    <rapriority>medium</rapriority></lan></dhcpdv6></page></pf_als_wifi></captiveportal>



  • So, I ended up resetting to Factory Defaults. This allowed me to do the exact same setup and it worked. I had all of my configurations saved in a document. It is odd how it just stopped redirecting to the authentication page.


Log in to reply