PfBlockerNG won't start after 2.4 upgrade



  • After upgrading to 2.4 (straight upgrade through web UI- did not reinstall pfSense for ZFS yet) the only thing that I have yet to fix is pfBlockerNG. It just wont start when I press the little "start" icon in the Dashboards services panel.  Nowhere does it give me an error (System logs  - General or pfBlockNG page logs). It just fails quietly, and I can see there are no pf rules in the WAN firewall rules (or any other interface for that matter).

    I did see a seemingly relevant forum post, I tried unchecking "keep settings" and removing/reinstalling package, no success there. I'm ok with losing my pfBlockedNG configuration, I can reconfigure it easily.

    Any idea?



  • I am far from a PFblocker expert, but are you referring to dnsbl service? I have been assuming that's not the main PFblocker functionality, instead that represents the DNS Block List only.  DNS Block list is enabled separately. on my system I have yet to configure DNS Block, and I see this service not tarted as well. I also see PFblockerNG stopping packets, so I know the main functionality is working.


  • Moderator

    Did you follow this quick start guide:    https://forum.pfsense.org/index.php?topic=102470.msg572943#msg572943

    Also the DNS Resolver must be enabled to use DNSBL.



  • I am far from a PFblocker expert, but are you referring to dnsbl service?

    I am only using GeoIP blocking (blocking China for example), I do not use (yet) DNSBL functionality.  The whole package simply won`t start, but does not give me any errors. I just upgraded to 2.4.1, and I seem to notice the pfBlockerNG version had changed too, but that didn't fix anything.

    While I don`t think it is relevant to my issue, DNS resolver is NOT running, but I do have "bind" up and running instead.



  • More info - I actually now see that it`s up and running (was that following  the 2.4.1 upgrade? possibly) but  the service tabs shows it stopped (little red "stopped" icon)

    Less of a problem, but still a minor one as I cannot rely on my dashboard to tell me what`s working or not.



  • Well, I answered my own problem which was basically that the service tabs shows the pfBlockNG DNSBL "sub-functionnality", but not pfBlockerNG`s functionality itself.

    Sorry about that


  • Moderator

    As an FYI, in the pfSense Dashboard - Services widget, you can click on the wrench icon and hide services that you do not wish to see…



  • you can click on the wrench icon and hide services that you do not wish to see…

    Thank you,  I did not know that


Log in to reply