Calcru: runtime went backwards



  • Доброе.

    У кого в консоли\логах сыпет вот таким:

    Oct 18 15:27:23 kernel calcru: runtime went backwards from 80 usec to 48 usec for pid 12 (intr)
    Oct 18 15:27:23 kernel calcru: runtime went backwards from 13724059 usec to 8110152 usec for pid 12 (intr)
    Oct 18 15:27:23 kernel calcru: runtime went backwards from 822462 usec to 502252 usec for pid 12 (intr)

    Решение - https://forum.pfsense.org/index.php?topic=57234.0  https://spuder.wordpress.com/2012/01/14/freebsd-calcru-runtime-went-backwards/

    You can try to change the timecounter (search around for kern.timecounter.choice and kern.timecounter.hardware) to see if that helps.
    Certain newer versions of vmware can have the clock flake out if it's using HPET.

    Thanks for the tip, I had the same issue with my pfsense vm, I tried the above commands:

    Current settings
    sysctl kern.timecounter.hardware

    Available options
    sysctl kern.timecounter.choice

    Руками значение kern.timecounter.hardware устанавливать не нужно. Заходим в System: Advanced: System Tunables,  добавляем (у меня Value - ACPI-fast - ваше может быть другим) и перезагружаем pfsense.

    ![System_ Advanced_ System Tunables_ Edit.png](/public/imported_attachments/1/System_ Advanced_ System Tunables_ Edit.png)
    ![System_ Advanced_ System Tunables_ Edit.png_thumb](/public/imported_attachments/1/System_ Advanced_ System Tunables_ Edit.png_thumb)



  • Вероятно, стоит добавить, что ошибка характерна для виртуализированой pf.




Log in to reply