504 Gateway Timeout on pfSense 2.4



  • Since upgrading to pfSense 2.4.0 I cannot reach the webinterface after a few hours (504 Gateway Timeout"). SSH also not responding after login, Ctrl+Z not does anything.
    Seems to be a different issue than the widely discussed 502 errors. Any (temporary) fix available except disabling pfblockerNG/DNSBL?



  • Reinstall and choose ZFS instead of UFS for the file system.





  • I recognize this error in the particular situation where I force an update and then view the update progress. However if I open another tab in my browser with the dashboard open and then close the pfBlockerNG tab immediately after hitting update, the dashboard tab keeps running fine and the timeout error does not occur. Also if I do get stuck on the 504, using a serial cable and reset the pfm / fpm (sorry i dont remember exactly which) and/or reset the webconfigurator things get back to normal and I can get the dashboard back.
    Somehow this feels like overstressing some resource on a very specific conditions that does not hinder pfsense but only the interface.



  • With not dashboard and no ssh, how is a re-install possible? Mine won't respond to ssh and all I get is 504 Gateway Timeout.

    Is it possible multiple refreshes of web-gui will let me see the dashboard?



  • Same issue here, with pfSense 2.4.1 and pfBlockerNG 2.1.2_1, after about 12 hours web gui and ssh not answer, console works as "text editor" - just type in and no answer. When Power-off button pressed there is some messages about disk buffer, and system power off after 5 mins, but on next boot disk checking start.

    Now i have disabled pfBlockerNG (not uninstall) and all works good a couple of days.



  • @Gektor:

    Same issue here, with pfSense 2.4.1 and pfBlockerNG 2.1.2_1, after about 12 hours web gui and ssh not answer, console works as "text editor" - just type in and no answer. When Power-off button pressed there is some messages about disk buffer, and system power off after 5 mins, but on next boot disk checking start.

    Now i have disabled pfBlockerNG (not uninstall) and all works good a couple of days.

    I'm having the same 504 gateway issue and I am thinking about disabling pfBlockerNG. You said it works "a couple of days" . Do you mean it works for 2 day and then you had to reboot it? Rebooting every 2 days would be a pain.

    I'd disable pfBlockerNG and start running pi-hole again if that were the case.

    Let me know!



  • I am also seeing this issue. Routing and internet work fine, but I can't get into the ui without rebooting.
    Let me know if there is any logs or information I can gather to help with this problem.

    I run on ESXi

    When I ssh in I see the following

    login as: root
    Using keyboard-interactive authentication.

    VMware Virtual Machine -

    thanks


  • Moderator

    Can you try the following patch?
    https://forum.pfsense.org/index.php?topic=110515.60



  • @BBcan177:

    Can you try the following patch?
    https://forum.pfsense.org/index.php?topic=110515.60

    Does it patch include in 2.1.2_2 version?



  • @BBcan177:

    Can you try the following patch?
    https://forum.pfsense.org/index.php?topic=110515.60

    I tried the patch, it worked for a few days.  But now the ui hangs when connecting. Seems like there is a memory leak somewhere or something.


Log in to reply