Nginx [error] fopen() failed client: 10.10.10.1



  • Oct 24 01:57:24	pfsense.localdomain		nginx: 2017/10/24 01:57:24 [error] 54655#100207: *18 open() "/usr/local/www/jslog/log.png" failed (2: No such file or directory), client: 10.10.10.1, server: , request: "GET /jslog/log.png?version=-bucket5&location=http%3A%2F%2Fstore.supermicro.com%2Fheatsink%2F1u-active-pro&referrer=https%3A%2F%2Fwww.goo&message=%23using_theme.artsy_albatross%20%23using_theme%20&tabname=oktab1957985944333016&conversation_id=XeeN8BzPMGoSZWZC1E9pr0W80JEzAjro&visitor_id=JmZaozgAzpscZE2I1E9pr0W80JE6Vao3&site_id=5194-535-10-9141&bucket=bucket5&level=count×tamp=1508835442069&properties=%7B%7D&recent_logs=%5B%5D HTTP/1.1", host: "log.olark.com", referrer: "http://store.supermicro.com/heatsink/1u-active-proprietary-cpu-cooler-snk-p0049a4.html"
    

    Random errors like this are starting to pop up in the logs. What's going on here?


  • Moderator

    I have never seen that before… Can you PM some of the other log entries? I assume this is in the pfSense system log?  Does it go away with pfSense 2.4.1?



  • This was present in the previous version of pfSense and still present in 2.4.1

    It was also present in the previous version of pfBlocker, and still present in the latest version. It was in the system logs. Whatever you need I'll get it for you. There are new entries today, it only happens on about 10% of sites I visit.


  • Moderator

    Do you use a proxy or any other packages?



  • Squid and Avahi are the only other packages running aside from pfBlocker.


  • Moderator

    Maybe this has something to do with Squid… pfBlockerNG doesn't utilize NGINX... and it definitely doesn't try to open() a URL that is blocked by DNSBL....  Maybe try to post in the Proxy forum and see if someone there has any more suggestions?



  • Most definitely I'll do that. I thought i'd try here first since it referenced 10.10.10.1 IP.

    Thank you for your continued support to pfSense <3


Log in to reply