Upgrade to 2.4.1 Broke Tunnel, OpenVPN Unable to contact daemon



  • We recently upgraded to 2.4.1 and our vpn tunnel immediately died. From Status > OpenVPN it’s just telling us that it’s ‘Unable to contact daemon’ and ‘Service not running?’

    I’ve tried restarting the service but it’s handled by a management daemon. Elsewhere in the forums, it’s recommended that you kill the openvpn process to restart it but openvpn isn’t even running. All I get back from a ps aux | grep openvpn is the grep command that’s running. If you run a service openvpn restart, the shell points you to /etc/rc.conf and says you need to set enable_openvpn to ‘YES’. The problem is that when you open /etc/rc.conf it says in big, bold letters that it’s been deprecated.

    Since this problem started we had purchased a new server, so we did a fresh install and backed up our old config. The new server is having the exact same problem. I’ve torn down the old openvpn instance and rebuilt it without any luck either.

    I’m hoping someone might have some more feedback on how to get the openvpn daemon back up and running.



  • Well - You could try to figure out the cause of it  (hours of geek work)

    Or you could take 2 minutes to do a fresh install of the last version, 1 minute to restore your configuration 1 minute too reboot.

    then 23 hours and 56 minutes to cuddle someone…  Its up to you.

    I say dig into the code and try to figure out why it failed…



  • We did a fresh install and restored our config but it didn’t change anything. This afternoon I’m going to try it again but I’m only going to restore our interface and firewall configs. Hopefully that works.



  • Hmmm - Time to role back to previous version and skip an update?



  • That’s looking like the only answer. I appreciate your feedback, kejianshi.



  • Sorry - Sometimes I can only think of the simple answers.  Well…  Most of the time.


  • Developer Netgate Administrator

    What is in the OpenVPN log for that instance? What about if you edit/save the instance, anything new in the log?

    Without knowing any details about why it’s failing, it’s impossible to offer advice on how to fix it



  • Some necroposting here. I encountered the same behavior upgrading an ancient installation.

    Came from 2.2.4
    -> 2.3.5. All OK
    -> 2.4.1. Broke OpenVPN servers. Service didn’t start. Tried re-saving one of the server configs on one tunnel (got like 10 endpoints on this install…) didn’t resolve the issue. For shits and giggles I continued the journey to the latest version.
    -> 2.4.2_p1. OpenVPN service starts as it should. All tunnels came up except the one I had re-saved in 2.4.1, which now was missing the Crypto in the Crypto column. Re-saved it again and it came back to life.

    So, if anyone taking the upgrade path similar to this, continue all the way up to 2.4.2_p1, do not re-save any OpenVPN server config when passing 2.4.1.

    Brgs,



  • I always like when someone says “Man - Why are you posting to such an old thread.”

    As if that necessarily means its now an irrelevant thread.  Good post.



  • Give me som’ karma then god dammit ;D for following up with such a excellent manners.

    Brgs,



  • Ok…  I gave you the “loud applause”.  Nothing a shot can’t cure.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy