Destiny 2 Strict NAT to Open? [SOLVED]

  • I tried turning on UPnp 88-65535 to the PC running Destiny 2 but NAT is still strict.

    How can I open up the NAT?

  • I had another similar question, about GTA V with no answers so far and i guess the same applies to this game. What i have found out so far is that the nat type at least become “moderate” instead of “strict” if you set up an outbound nat-rule that makes all of your ports static to your gamingdevice. It should then work to get it “open” by just enable UPnP as you already have, but no luck for me. I guess the best solution if you really dont wanna connect your gamingrig besides your pfsense-box is to live with the “moderated nat”  😞

  • i’d be fine with at least a moderate NAT. Would you mind posting your Advanced Outbound NAT rule screenshot?

  • Nevermind, I just needed to select the appropriate Gateway. The computer I’m playing off of is behind a gateway group of tiered VPNs so I had to match that up.

    Here’s the config that got me to moderate (+UPnP on the one desktop only).

  • I was just able to get to “Open” without using UPnP:

    1. Inbound NAT Port Forward rule for ports 3074 and 3097 to IP of Destiny 2 PC
    2. Inbound firewall rule on WAN interface (may vary) with IP of Destiny 2 PC as the destination and ports 3074/3097 (this should be auto-created assuming you went with the “Add associated filter rule” option when making the inbound NAT above)
    3. Outbound NAT rule with source of Destiny 2 PC, source port UDP 3074 and 3097 with Static Port option checked.  I have Hybrid NAT selected for my Outbound NAT mode.

    This post is what ultimately helped me out, the static port option being the missing link for me:
    “The STUN-based networking that PS4/Destiny want to use cannot work with PFSense’s default behavoir of randomizing source ports.”

    Again I opted not to use UPnP and went with manual port forwards.  Make sure to remove any previous UPnP config specific to this, or disable it.  When I had it running in parallel accidentally it sometimes was Open and sometimes was Strict, that’s when I noticed it still making UPnP rules after I had the static setup running.

  • I was working on this problem over the weekend trying to get Destiny working on my PC.

    I was able to get the Strict NAT warning in the Director to go away by doing the following.

    1.  Make sure PC running game has static IP.
    2.  Create static NAT rule for PC.

    Please note that I no longer see the Strict NAT warning in the director but not sure where to go to check the actual NAT Type the game is now detecting.

    Not sure why the Stict NAT warning went away without having to enable UPNP or creating the NAT and Firewall rules lot of others have suggested.

  • You can check your NAT status, in settings under network.


© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy