PfSense 2.3.5-RELEASE now available!

  • Galactic Empire

  • According to the update instructions:

    Upgrading to pfSense 2.3.5-RELEASE

    Updating to pfSense 2.3.5 from pfSense 2.3.4 on an amd64 installation that could otherwise use pfSense 2.4.x requires configuring the firewall to stay on pfSense 2.3.x releases as follows:

    Navigate to System > Update, Update Settings tab
        Set Branch to Security / Errata Only
        Navigate back to the Update tab to see the latest pfSense 2.3.x update

    The same change is required to see pfSense 2.3.x packages for users staying on pfSense 2.3.x.

    If the update system offers an upgrade to pfSense 2.3.5 but the upgrade will not proceed, ensure that the firewall is set to the correct update branch as mentioned above. If the firewall is on the correct branch, refresh the repository configuration and upgrade script by running the following commands from the console or shell:

    pkg install -fy pfSense-repo pfSense-upgrade

    Firewalls running 32-bit (i386) installations of pfSense software do not need to take any special actions to remain on 2.3.x as they are unable to run later versions.

    However, I'm not seeing Security / Errata Only as a choice.

    Only development and stable.

    Wondering if I should run pkg install -fy pfSense-repo pfSense-upgrade anyway or do something else?

    Thanks in advance.  I only have 1 32 bit system out there but it works very well, so its nice to keep it going a bit longer.

  • To get it to show up, I switched to developement, saved it.  Checked for an update…

    Then switched back to stable, saved it, checked for an update.  It saw the update then.  All good.

  • worked as documented on my pfsense.

    Thanks for still supporting "the old version"

  • Looks like the nano images are missing?

  • Maybe copying to the mirrors wasn't finished when you checked?
    I just saw them and downloaded versions relevant to me.

  • Yeah, they are there now. Must have arrived later than the other files.

  • So, I'm new to this board…LOVE pfsense. I have an sg-2220 which I understand is no longer available...

    That said, i recently had an issue where all my packages disappeared and worked with a pfsense rep to address the issue. I think it was Chris or Matt MacMahon (e.g. forgive the accuracy, I can't remember his name exactly). VERY knowledgable guy!

    Here's my question. Why am I on an older version of pfsense (e.g. 2.3.5 RELEASE p1)  now? Prior to his assistance, I was on a newer version of pfsense. Now, I realize i'm working now, and don't want to be on a newer version WITHOUT being functional...However, I would like to know the reasoning.

    Thanks for any input on this topic.

    Respectfully, Ken.

  • LAYER 8 Netgate

    Why am I on an older version of pfsense (e.g. 2.3.5 RELEASE p1)  now?

    What branch is selected in System > Update, Update settings?

    What is shown as the current base system, latest base system, and status in System > Update

  • please help from pfsense companion, after update to version 2.3.5 there is error message

    There were error(s) loading the rules: /tmp/rules.debug:19: cannot define table bogonsv6: Cannot allocate memory - The line in question reads [19]: table <bogonsv6> persist file "/etc/bogonsv6"
    @ 2018-05-06 16:54:42

    Thank you for your help

  • 5 seconds searching this forum and you would already have your answer.

Log in to reply