Problemas Squid y HTTPS/SSL Interception



  • Saludos gente

    Soy nuevo aqui en el foro y accedo a uds para que me ayuden con estas interrogantes

    1. Tengo la version pfSense 2.3.5-DEVELOPMENT (amd64) y estoy intentando configurar el squid, pero cuando intento abrir una pagina https me sale el siguiente mensaje
    " _**Conexión segura fallida

    Ha ocurrido un error durante una conexión a www.google.com. SSL ha recibido un registro que excedía la longitud máxima permitida. Código de error: SSL_ERROR_RX_RECORD_TOO_LONG

    La página que está intentando ver no se puede mostrar porque la autenticidad de los datos recibidos no ha podido ser verificada.
        Contacte con los propietarios del sitio web para informarles de este problema**_."

    Ya he configurado el certficado pero sigo sin conseguir que las paginas se puedan ver

    2. La otra es q tengo un pfSense de prueba detras de un proxy, le configuro el proxy en la interfas web y la primera ves q intento instalar una paquede me salen todos, luego de mandar a instalar se queda inicializando el proceso y de ahi no pasa, y despues cuando lo intento de nuevo me envia el mensaje de que no puede resolver la informacion de los paquetes….

    Agradeceria que si alguien tiene respuesta para estas interrogantes me ayudaran pues me estoy rompiendo la cabeza y no consigo resultados



  • hola, postea algo de la config de tu pf, por ahi algo de los  ssl bump, o mala config, va a ser mas fácil :)
    revisa que aparecen muchos resultados sobre este tema,
    https://www.google.com.ar/search?q=ssl_error_rx_record_too_long+pfsense&rlz=1C1EJFA_enAR737AR737&oq=SSL_ERROR_RX_RECORD_TOO_LONG&aqs=chrome.4.69i57j0l5.5572j0j7&sourceid=chrome&ie=UTF-8

    mira esto, esta muy bonito, por ahi te lleva a alguna solución esta guia: https://forum.pfsense.org/index.php?topic=72528.0



  • saludos elbocha01
    Gracias por la respuesta, pero recuerda q mi pfsense esta detras de un proxy y no me permite descargar los paquetes  de internet…hay veces q si y otras no, vaya q no se cual seria el problema.
    con respecto a la configuracion del proxy he echo la normal para un caso de pruebas, incuso sin filtrar contenido ni autenticando usuario. Si hay algo en especifico q tenga q ilustrar seria bueno q me lo dijeras...Saludos



  • podes postear configuracion de la pantalla general y las reglas de firewall



  • Hola

    1 Estas usando squid transparente? si, es asi en el modulo SSL Man In the Middle Filtering, SSL/MITM Mode que estas usando *Splice ALL o *Splice Whitelist
    2 Que DNS tienes configurados en el modulo *Use Alternate DNS Servers for the Proxy Server (aca debes usar los dns de los equipos clientes que pasan por tu proxy)
    3 En las Rules de los equipoes clientes que reglas tienes establecidas? puedes colocar print de ello.



  • Te  envío este link te va ayudar en la configuración  https://openschoolsolutions.org/pfsense-web-filter-filter-https-squidguard/



  • Buenas estimado, dale una mirada a este video donde se explica de como hacerlo con squid+squidguard. Bastante me ayudo luego de visitar varios post e incluso buscar la doc. espero te sirva: https://www.youtube.com/watch?v=X1t_KPy9znk

    Yo lo hice de modo no transparente con squid + squidguard y como para reportes y no andar mirando el log instale lightsquid.

    Te informo que luego de terminar la configuración debes eliminar las reglas de paso a través de LAN para todo y añadir una que envíe el trafico al firewall.

    Saludos.


Log in to reply