E2guardian4



  • Installed the E2guardian4 package this evening but having issues getting it to start filtering. I see the below error in the logs. I do not have a CA configured and have selected manual local proxy 127.0.0.1 at port 3128. But the below error seems that E2 is still looking for a CA at port 8888.

    /pkg_edit.php: The command ‘/usr/local/etc/rc.d/e2parent.sh start’ returned exit code ‘1’, the output was ‘FATAL: No valid signing SSL certificate configured for HTTP_port 127.0.0.1:8888 Squid Cache (Version 3.5.27): Terminated abnormally. CPU Usage: 0.016 seconds = 0.016 user + 0.000 sys Maximum Resident Size: 47616 KB Page faults with physical i/o: 0’

    No valid signing SSL certificate configured for HTTP_port 127.0.0.1:8888



  • Was the package pulled out? I don’t see it on the list of available packages anymore.



  • Never mind. Looks like I can see the E2guardian4 package if I add marcelloc unofficial repo for WPAD package.



  • Make sure you have the unofficial repo added  and make sure you’ve got that CA generated for SSL MITM. After setting that up in E2G settings, it should work fine.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy