Updraded to Quad Core Atom E3845 PIA VPN Now Very Slow 2.4.1



  • Hi All,

    I have been running Pfsense in Hyper -V on both 2.3.4 and 2.4.1 with 2 cores of an E3 1226 V3 XEON and I am able to basically max my internet speed using PIA @ 200Mbps. I got tired of losing internet when having to work on my server with Hyper-V so I purchased a Protectlii.

    Long story short, max I can get now is 70ish Mbps. I tried 2.3.4 and 2.4.1. CPU usage from Tops seems ok so I don't know what gives. I even get max performance on an old AMD 9550 quad core phenom.

    Tops CPU usage
    2.3.4 20%
    2.4.1 60%

    Any thoughts on what to check? I am running 2.4.1 on my AMD box and running tests on the protectli using a VM at same time.

    https://www.amazon.com/Firewall-Micro-Appliance-Gigabit-AES-NI/dp/B0742P83HY/ref=sr_1_2?ie=UTF8&qid=1510443999&sr=8-2&keywords=protectli&dpID=41%2Bq3mZ-crL&preST=SX300_QL70&dpSrc=srch

    Quad Core Atom E3845 1.91GHz, 2MB L2 Cache
    CPU Supports AES-NI
    4GB DDR3L RAM and 32GB mSATA SSD
    4 Intel Gigabit Ethernet Ports



  • I installed Pfsense 2.4.1 on my spare system i5 7500T and rebuilt PIA VPN from scratch and I have the same problem. So I would guess the PIA VPN setting that needs to be different?

    Original settings = 200Mbps internet speed

    I have changed these settings

    On 2.4.1 with i5 processor = 20Mbps

    explicit-exit-notify 2
    ifconfig-nowarn
    tls-client
    persist-key
    persist-tun
    persist-remote-ip
    remote-cert-tls server
    keepalive 10 120
    reneg-sec 0
    auth-nocache
    fast-io
    sndbuf 524288
    rcvbuf 524288
    

    Or

    persist-key
    persist-tun
    persist-remote-ip
    remote-cert-tls server
    keepalive 10 120
    reneg-sec 0
    auth-nocache
    fast-io
    sndbuf 524288
    rcvbuf 524288
    

    or PIA suggested settings

    persist-key
    persist-tun
    remote-cert-tls server
    reneg-sec 0
    

    Compression is adaptive LZO legacy. looks closest to 2.3.4 adaptive compression. So what gives here?



  • I’m using the latest pfsense on a sg2220 with strong encryption.. my udp Connection is my FULL internet speed.. you might email PIA for the directions

    I also have aes ni enabled



  • Well i seem to be back to normal. I had the test pfsense behind a VM and that seemed to be affecting it. Connected my i5 Pfsense to my main network and performance is ok. It's a bit erratic if I change anything, going from 200 Mbps to 40 then back. Could be PIA.



  • I have the same issue and the same device from amazon that sheen73 has,  I have a Gigabit connection, with PIA defaults I only get 40Mbps :(
    In the UI I changed the Send/Receive Buffer to 512K and UDP Fast I/O to true.

    My speed increased to 130Mbps… all my NICs support Gigabit.


Log in to reply