Squid - proxy test don't detect proxy



  • I have a standard Squid proxy setup and it used to pass proxy tests (like http://www.all-nettools.com/toolbox/proxy-test.php)

    And now tests show - no proxy detected !

    I don't know even know where to start troubleshooting this.
    Any help is appreciated !

    Thx



  • And now tests show - no proxy detected !

    That should be a good thing.  You don't want external sources knowing you're going through a proxy server.



  • @KOM:

    And now tests show - no proxy detected !

    That should be a good thing.  You don't want external sources knowing you're going through a proxy server.

    @KOM how do i test it then?



  • Services - Squid proxy server - Realtime.

    If everything is working then you should see URLs scrolling by in realtime as your users access pages.

    Back to what I was saying about masking your proxy, make sure you have the following set:

    X-Forwarded Header Mode: delete
    Disable Via header: checked
    Suppress squid version: checked



  • Thanks! Your statement that proxy should not be detected contradicts all videos I've see on this topic tho … odd...



  • The videos are all wrong.  Kom is right.

    Frequently, advertising that your traffic goes through a proxy will get you blocked and end up with some form of captcha way more often than necessary.



  • @kejianshi:

    The videos are all wrong.  Kom is right.

    Frequently, advertising that your traffic goes through a proxy will get you blocked and end up with some form of captcha way more often than necessary.

    It's unfortunate as many people are using videos on youtube to learn things and pfsense in particular.
    The reason I was wondering about the squid proxy as I use also antivirus and it stopped detecting  test files from http://www.eicar.org/85-0-Download.html

    Not sure WTH is going on ? …



  • You likely have a broken squid cache.  I'd delete and rebuild the cache.  Start there.

    This problem of yours is a regular subject here, so the answer is already in the threads.



  • Tried that already with no luck :(

    I guess I have to live with the idea it was not doing much anyway…



  • Sounds very broken. 
    Sorry.



  • AV is best done on the client.  I don't know how effective the Clam AV signatures are, or how effective it is at stopping anything other than the obvious stuff.  And it's one more thing to give you problems with your Squid config.



  • @KOM:

    AV is best done on the client.  I don't know how effective the Clam AV signatures are, or how effective it is at stopping anything other than the obvious stuff.  And it's one more thing to give you problems with your Squid config.

    Well AV does not worry me much.  It's more about oveall health of my pfSense router and it used to do all of this before 2.4.1 uograde and now no.
    I spent some time on this https://github.com/darold/squidclamav/issues/42 with no result.  BTW I see no errors on squid site.  So just keep trying :)



  • I remember when I built my first pfsense.  I just started adding every feature that looked cool and later realized that most of it I didn't need at home.  Squid and clam av were among those that I found not very useful for my home scenarios.  My clients were either windows which had far superior AV or linux systems which need no AV.  So, I don't use those now.

    There are scenarios where it is useful though.  For me, I used it to control what my kids could see on the net.

    Later when they reached their teen years I turned it off…


Log in to reply