Monthly traffic reports?



  • Hi all,

    I just upgraded my old Asus RT-AC66U (w/ Merlin) to a QOTOM box with pfsense.

    With Merlin I had a nice monthly traffic graph where I could view my total upstream/downstream traffic month-to-month. I can't seem to get something similar working on pfsense. I have "Traffic Totals" installed, but it seems to be horribly broken and does not correctly log traffic at all (days reported as 0, days missing completely from report, etc).

    bandwidthD seems nice for last-day/last-week/etc but does not seem to do monthly reports? I want to review my historical totals for June, July, August, etc.

    Similarly, ntopng has some cool stuff but I can't figure out how to replicate this simple functionality. Is it hidden behind a paywall?

    Any advice on simply having monthly traffic reports? Per-IP would be amazing but even just global would be great, as I had that with Merlin and don't have it now…

    Thanks!



  • Nothing? :(

    This seems like such an essential feature…



  • Im not having any issues with Traffic Totals package myself. Maybe uninstall and reinstall.. ?



  • @chpalmer:

    Im not having any issues with Traffic Totals package myself. Maybe uninstall and reinstall.. ?

    I've tried that a few times, unfortunately. I just get bogus data that never "updates" after the last reset date. Graphing is enabled.

    I'm using pfsense 2.4.1-RELEASE. Attached file is what I see right now (today is 11-26, last time I tried uninstall/reinstall/reset was 11-18).

    I just updated to 2.4.2 and will try uninstall/reinstall again…

    ![Screen Shot 2017-11-26 at 12.47.35 AM.png](/public/imported_attachments/1/Screen Shot 2017-11-26 at 12.47.35 AM.png)
    ![Screen Shot 2017-11-26 at 12.47.35 AM.png_thumb](/public/imported_attachments/1/Screen Shot 2017-11-26 at 12.47.35 AM.png_thumb)



  • On your traffic totals page, have you clicked Display Advanced and then "Enable Graphing"?

    Id hit "Reset" as well to make it re-write the database.




  • @chpalmer:

    On your traffic totals page, have you clicked Display Advanced and then "Enable Graphing"?

    Id hit "Reset" as well to make it re-write the database.

    Yes, graphing is enabled and I have reset a few times now…



  • Hmm..  Working here fine.

    Im stumped!    :o



  • lot of time passed by, and I'm now at this problem, graphic totals shows day by day totals without problems, but stop updating monthly :(

    that's strange. the last thing that I have to test its to remove, reboot, and install it again. I did that without the restarting



  • OK, I reset everything just to figure out that is summing the traffic under "February" despite that the actual date of the server is in March….



  • attachment on day and month report

    ![Screenshot - 2018-03-13 20 00 43.png](/public/imported_attachments/1/Screenshot - 2018-03-13 20 00 43.png)
    ![Screenshot - 2018-03-13 20 00 43.png_thumb](/public/imported_attachments/1/Screenshot - 2018-03-13 20 00 43.png_thumb)
    ![Screenshot - 2018-03-13 20 02 13.png](/public/imported_attachments/1/Screenshot - 2018-03-13 20 02 13.png)
    ![Screenshot - 2018-03-13 20 02 13.png_thumb](/public/imported_attachments/1/Screenshot - 2018-03-13 20 02 13.png_thumb)


  • Banned

    How about looking into the part of the forum dedicated to this topic, lot's of information there: https://forum.pfsense.org/index.php?board=62.0



  • Any luck on this? It seems like the Traffic Totals plugin only half works. It knows how much data is moved on a day but it doesn't know how to properly total the values. I tried a bunch of different values for "Start Day" but nothing seems to help.



  • There are definitely issues with the Status_Traffic_Totals package… mine's showing two "11/2017" months, and data for March 2018 is being shown as February as a result.



Log in to reply