PfSense 2.4.2-RELEASE Now Available!


  • Rebel Alliance Developer Netgate

    Details on the blog:

    https://www.netgate.com/blog/pfsense-2-4-2-release-now-available.html

    If you need assistance or have issues with the upgrade, please start a new / separate thread in an appropriate board.

    Thanks!



  • Pretty graphs…  Easier on the eyes.



  • So far 2.4.x + has been a derpy mess.

    At the moment I have two boxes who can't see any installed packages (even though they're available in the console and I can use them) and that boxes won't check for updates or new packages.

    I also get the nginx 504 message I think it is:  https://forum.pfsense.org/index.php?topic=110515.0;topicseen

    I also can't check for updates like these guys:  https://forum.pfsense.org/index.php?topic=139276.0

    OpenVPN stops working, I can't SSH, I can't get to the webUI…the box has to be physically rebooted and with a holiday in the US upon us who wants to go do that for a customer that needs great up time?

    I regret upgrading to 2.4 from 2.3 for this client!!!

    HELP!










  • Downgrade.  But for me its working fine.



  • I'd say there is every chance you have broken something or something has broken that can be fixed.  What packages are you using?



  • I'm sure it can be fixed but I can't find what's broken!

    From /usr/local/pkg - I use:

    mailreport.xml            openvpn-client-export.xml servicewatchdog.xml
    miniupnpd.inc            pfblockerng              servicewatchdog_cron.php
    miniupnpd.xml            pfblockerng.xml          snort

    I wanted to update the pfblockerng package to the latest after updating to the 2.4.2 release on the two fw's that are derp on the nginx 502 lockup problem but I can't do it form the gui.  Can I from the cli?

    Seems that pfbNG is what's causing the nginx problem.

    Thanks for any help!

    I did contact a colleague and asked him to look at his and his fw on 2.4.1 says there's an update to 2.4.2 and seems to be working correctly.  These are the only two I have in this state of derp.

    Oh!  I will also say it's not updating the graphs and thermal sensors either which strikes me as odd but a hint at what might be going on…



  • O…M...G.

    I was using the new FF 57 or whatever just came out.  I tried chrome for shits and giggles (and I hate Google which is why I have it as a terd option).

    All the stuff WORKS in chrome!  Gawd.

    How dumb.  Maybe I need to refresh FF or perhaps something.

    So my problem was related to only FF!!!

    Sorry for the forum spam but maybe this will help people LOL.



  • There was a thread recently about how all the misfortunes of life were due to a pfsense upgrade.
    Mine was particularly bad…  Still suffering.

    Coincidence...  It happens.



  • Smooth upgrade from 2.4.1 to 2.4.2 - thanks for all the hard work you guys put into this.



  • I run pfSense on ESXI 6.0 latest update. I removed "kern.vty=sc" of /boot/loader.conf.local (I had this VT issue with pfSense 2.4.0).

    Then I upgraded via Shell to 2.4.2 and everything is working fine (No VT issue and no Framebuffer issue https://redmine.pfsense.org/issues/7975 )

    So thank you for your work!

    One question remains: Is pfSense still based on PHP 5.6 and why is it not upgraded to the much faster PHP 7.1.2 or 7.2 (release date on 30 November)?


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy