Converting rules to Alias type and errors when disabling package



  • I used the trick of replacing all the pfB_ with pfb_ in the descriptions and did the following:

    Then Disable the package.
    Edit all of the IPv4/6/GeoIP aliases to be "Alias type"
    Then re-enable the package…

    It seems to work.

    But I notice that after this modification when I disable pfB I get tons of notifications, consequently my email account gets bombarded (as I have email notfications on.) Am I doing something wrong here or is there a way to suppress these notifications.

    The errors on in the form of "Unresolvable source alias 'pfB_Asia_v4' for rule 'pfb_Asia_v4 auto rule'..." , they only stop from appearing when I re-enable pfB.



  • When you disable pfBlockerNG, it removes the aliases and FW rules it created (auto-rule).
    In your case of Alias type table, you have to disable the pfb_ FW rules before disabling pfBlockerNG.



  • @RonpfS:

    When you disable pfBlockerNG, it removes the aliases and FW rules it created (auto-rule).
    In your case of Alias type table, you have to disable the pfb_ FW rules before disabling pfBlockerNG.

    I'm assuming this can be scripted in some way, as I have far too many to do on an individual basis…

    Found it, in the [filter][rule][0][disabled] array, when using pfSsh.php

    EDIT: i tried to disable a rule to see a change in the [filter][rule][0][disabled] variable, and interestingly enough it didn't change from being empty, i would have expected to be set to "yes". am i missing somthing?


Log in to reply