Routed Error: - impossibly lacks ifp


  • Rebel Alliance

    I have several OpenVPN services on my server.
    The latest one I am attemping to configure will not route to the client correctly.

    I have a Peer2Peer Tunnel (tun tcp) Network 10.200.20.0/24 between my server (10.11.200.0/24) and client (10.11.211.0/24).

    I can route from the client to the server (to 10.11.200.254), but I can NOT route from the server to client (10.11.211.254).
    However; I can get to the client from the server on 10.200.20.211 - which is the address allocated in the "CSC" Client Specific Overrides.

    The route is not being added correctly even though it is in the OpenVPN server "Custom Options" - as follows:
    route 10.11.211.0 255.255.255.0 10.200.20.211;
    When I add this route; the assigned OpenVPN Gateway goes offline.

    The System Logs / System / Routing show the following:

    routed 89460 static route 10.11.211.0 (mask 0xffffff00) –> 10.200.20.211 impossibly lacks ifp

    Firewall rules are: Everything open under LAN, and everything open under OpenVPN .


  • Rebel Alliance

    I solved my routing problem by creating outbound rules and static routes.
    Possibly not the nicest solution, but taking to a different distro has it's issues.

    It seems that when you add a route, the dynamic gateway changes address from x.x.x.1 to x.x.x.2
    I don't understand why this happens.

    It also appears that the 'OpenVPN Server/Tunnel Settings/IPv4 Remote Networks' does not pushthrough to the OpenWRT Router. Is this an 'iroute' command?



  • @Gil Hi, How did you solve this problem? I upgraded from 2.4.4-RELEASE-p2 to 2.4.4-RELEASE-p3 and started having the issue after a couple of days. Please share your solution.


Log in to reply