Не работает CARP Virtual IP



  • Всем доброго времени суток.

    Прошу помочь разобраться в следующей проблеме.

    Имеется две машины на Hyper-V на обоих установлен pfSense (2.4.1), шлюз настроен как High Availability кластер. Имеется по 5 интерфейсов в каждом и соответственно по 5 Virt IP (CARP)

    • WAN 1 (Провайдер А)

    • WAN 2 (Провайдер B)

    • LAN

    • SYNC

    • OPT1 (для внутренних нужд)

    Проблема в том что IP принадлежащий провайдеру B не работает когда он используется в качестве CARP адреса (не отвечает на ICMP запросы, провайдер не видит активной сессий с этого IP, не работает кароче).

    Айпишники 100% рабочие, в фаерволе разрешено все, спуфинг мас адресов включен на всех интерфейсах, провайдер говорит никаких блокировок для b2b клиентов не использует. Провайдер А настроен точно так же, у него все нормально.

    В чем может быть проблема?



  • Доброго.
    Может тут чего есть https://forum.pfsense.org/index.php?topic=139884

    P.s. Сетевые в ВМ - паравиртуальные? Может стоит попробовать e1000 использовать ? Есть в гипер-в такие или аналог?



  • В общем проблема оказалась в провайдере. Позвонили уже админы провайдера и сказали "Работа протокола CARP на нашем оборудование не поддерживается." Такие дела.



  • @Hitty:

    В общем проблема оказалась в провайдере. Позвонили уже админы провайдера и сказали "Работа протокола CARP на нашем оборудование не поддерживается." Такие дела.

    это не удивительно. Дело в том, что мак адрес карп интерфейса идёт с определённого мак-диапазона. Чтобы работать с этим маком - требуется поддержка маршрутером. У меня аналогично было с длинком DES3028. Я писал в саппорт длинка, и  после моего тикета длинк выпустил прошивку для совсем давнешнего EOL  железа, за что ему спасибо.


Log in to reply