WLE200NX wireless card not detected pfSense 2.4.x - What did I do wrong?

  • Hello,

    I've purchased a WLE200NX wireless card which I strongly suspect should work fine with pfsense, but it, along with a dozen or so other atheros wireless cards that I've tried are not being detected by pfSense. The process I used to test if these cards would work for me is as follows.

    Remove old adapter/install new adapter
    fresh install pfsense 2.4.x
    when the installation prompts to assign network interfaces, the wireless card is not listed (only the ethernet adapter is listed) - at this point it is assumed the card is not compatible.

    I used to have an old acer aspire one that I reinstalled pfsense on a handful of times over the years and when fresh installing pfsense, the wireless adapter would be listed in the interface assignments portion of the installation.

    I tried a handful of laptops with various atheros wifi cards, including the WLE200NX - These laptops will detect the wireless cards and can use them with Windows, but pfsense does not appear to detect them.

    I see others on these forums using the WLE200NX, and in additionally it works with windows so I'm not suspecting a bios/firmware issue..

    What am I doing wrong? Is there a process I can follow somewhere or can anyone share a similar experience where they were able to get pfsense working on a laptop with a wireless adapter?

  • Hi,
    on which hardware do you install the wifi card?
    On some boards the mPCI slots only supports usb devices!
    Some more information you'll finde here: https://forum.pfsense.org/index.php?topic=136224.0

    best regards

  • Well that's an added revelation that I was completely unaware of… Thank you

    However, because these cards work fine in another OS, is the notion that the 'mPCI slot may only support usb devices' somewhat irrelevant here?

  • Hhm, not sure how related the referenced thread is. But I can confirm the WLE200NX is generally working with pfSense 2.4.x. I am using an APU2C4 mainboard. What mainboard are you using?

    I am currently struggling with a smaller issue with initialization after reboot and adjusting channel width https://redmine.pfsense.org/issues/7986. Apart from this the card is stable.


  • Netgate Administrator

    That card should work fine (assuming the slot supports it).

    Check the output at the command line or from Diag > Comnmand Prompt of :

    pciconf -lv

    You should see it listed there as:

    ath0@pci0:4:0:0:	class=0x028000 card=0x3099168c chip=0x002a168c rev=0x01 hdr=0x00
        vendor     = 'Qualcomm Atheros'
        device     = 'AR928X Wireless Network Adapter (PCI-Express)'
        class      = network

    If it's there it probably just needs to be added correctly. The procedure changed slightly since 2.3.

    Go to Interface > Assignments > Wireless Tab. Hit 'Add' you should see 'ath0 (Atheros 9280)' as an option. Give it a description and save that.

    Now it should appear as available for assigning like any other interface.


  • Hi everyone,

    Thanks very much for your help so far, I really appreciate it!!

    Unfortunately I am not able to verify what motherboards I was testing with as those devices have been donated elsewhere

    However, I have purchased an SG-3100 from netgate. The sales rep assures me that the WLE200NX was sold for this device in the past. I have said wireless card installed in the SG-3100 now, and the card is STILL not being detected.

    Words cannot convey the frustration this problem has caused me. The financial investment to harden my network against wpa2 KRACK is now well beyond sufficient to be embarrassing…

    So basically, I opened the SG-3100, installed the WLE200NX and screwed it in place. Booted up the device, connected a LAN cable for my laptop, connected to the web interface, went to interfaces > Assignments > Wireless tab - in there, parent interface has only 'none  available'

    I tried to go to diagnostics > Command prompt and execute pciconf -lv as a shell command however there is no readout above. I tried pciconf without the flag to see if I would get some output and the pciconf usage instructions were displayed, so the output is working.

    I'd really appreciate any help you guys can provide to get this Wifi card working!

  • @Preacher22:

    However, I have purchased an SG-3100 from netgate. The sales rep assures me that the WLE200NX was sold for this device in the past. I have said wireless card installed in the SG-3100 now, and the card is STILL not being detected.

    I don't know the Netgate SG-3100. But I've take a quick look into their manual.
    There is no discription about a mPCI-Slot onto SG-3100!

    I think you should ask netgate for the mPCI support of their SG-3100 directly. Normaly you get one year of gold support by netgate when you buy an SG-3100.

    best regards

  • I have no idea what to say… I feel like I’m in an episode of the twilight zone

    I just double checked my email and the sales rep definitely said a wifi card can easily be added to all of their routers except the sg-1000

    I replied and asked which wifi adapter would work and I received a response from the same rep who said they used to sell a wifi kit with the wle200nx.

    So I purchased this router and a wle200nx specifically to use the wle200nx. I think I need to call Netgate

    In the meantime if anyone wants to take Netgate’s side here and believes the wle200nx should work with the sg-3100 I’d really appreciate any suggestions I can try...

    Thanks again for everyone’s help so far!

  • Hi Preacher22,
    I've took a closer look to the SG-3100 webpage. The i found this: "Flexibility is built in to the SG-3100 with upgrade options such as a m.2 SATA SSD, LTE cellular, or mPCIe Wi-Fi."
    So at all the SG-3100 ssems to support an mPCIe slot!
    Sorry for that. But in the manual there is no word about such an option.

    So the best is to make an call to netgate why the wifi card won't work into their SG-3100!

    best regards

    PS: I use 2 Atheros 9280 wifi cards (i.e. WLE200NX) into my fw box an they working as expected. But the box use an intel cpu an not an arm cpu.

  • Hey Monstermania,

    I really appreciate that you took the time to take a closer look and I’m relieved to hear that it appears that the SG-3100 May support the wle200nx after all.

    When I can reach Netgate I will update the thread and let you guys know what was said

    As before, any additional suggestions are welcome in the meantime!

    Thanks again monstermania and everyone else for your suggestions and efforts regarding this issue

  • Netgate Administrator

    Sorry to have to reply here with bad news but I have to say I have tried to use that card in the SG-3100 and never managed to make it work.
    We are investigating it but it appears to be fairly low level since it is not seen even by the uboot pci listing.

    Other mPCIe cards do work in the mPCIe slot though.

    Currently I using an m.2 wifi card in the one I have here and that works just fine. Using an Atheros QCNFA335 card which is 2.4GHz only.


    Edit: Wrong part number!  ::)

  • No no thats great news, anything that helps me understand whats going on here…

    Purchasing another wifi card is very minor, I'll pick up one of the cards you suggested.

    In the meantime, please do let me know if you manage to get the wle200nx working. More importantly though, it would be good to understand more about why the wle200nx would be having trouble with the sg-3100 I would be very interested in your findings as they develop. Do you have another thread going that I can monitor?

  • Netgate Administrator

    This is probably the best thread for that. We do have an internal ticket open to track the issue but I don't think it's public currently. I'll update the thread with any progress.

    I'm hoping to test a NFA222 based card but haven't got hold of one yet. It should be similar to one I'm running but has a chipset that can do 5GHz too. The FreeBSD 11 drivers should support it. They seem to be far more rare though.


  • Sounds good! Thanks again for your efforts with this!

    I received an update from Netgate, indeed the wle200nx was supported but is confirmed by them as being currently problematic. No details were provided but they were nice enough to offer to pass along a request for a confirmed working wireless card to their technicians. So that was pretty nice of them!

    I’ll update this thread with that information when I receive it.

  • Coincidentally the attending technician to my request is also using the Qualcomm Atheros QCNFA335 in his SG-3100 so this card is indeed currently supported…  A 5ghz option would have been a nice perk but I'm perfectly happy with 2.4ghz anyhow.

    Looking forward to seeing that NFA222 card posted in the known working wireless cards section for you! Good luck!!

  • Netgate Administrator

    Updating for completeness. The Qualcomm Atheros QCNFA222 works just fine in the SG-3100. It is 2.4/5GHz and 2x2 so significantly better than the QCNFA335.


  • This post is deleted!

  • Hey @stephenw10 thank you for complementary information. I'm considering buying SG-3100 with wifi module, but does the case have holes for antennas please?

  • Netgate Administrator

    Very late to the party here but no it doesn't have predrilled holes. You can drill holes or use adhesive type flat antennas on the inside of the case.


Log in to reply