Pb : 1 Wan - Multi GW



  • Bonjour a tous et merci par avance pour votre aide

    Je possede un PF v2.4.1

    J'ai sur ce PFsense deux port reseau, 1 LAN et 1 WAN
    sur le Wan j'ai 2 GW
    WAN : 192.168.200.10
    GW1 (default): 192.168.200.1 (SDSL 4M) (Monitor ip 8.8.8.8)
    GW2 : 192.168.200.2 (VDSL 30M) (Monitor ip 8.8.4.4)

    J'ai configuré 2 groupes de GW
    GRP_VPN : GW1 puis GW2 (Menber down)
    GRP_INTERNET : GW2 puis GW1 (Menber down)

    Donc un Groupe pour l' OpenVPN site à site avec mon site principale
    et un second groupe pour le surf

    J'ai créer une règle sur le LAN pour que toute les ip LANNET utilise comme GW mon groupe GRP_INTERNET

    Le surf fonctionne correctement mais je ne comprend pas pourquoi mon flux Internet passe toujours par ma GW1 alors que la GW2 donc à première vu mon GRP_INTERNET ne se comporte pas comme prévu…

    J'ai l'habitude de configurer des PFSense en MultiWan mais jusqu’à présent je dédiais une interface pour chaque WAN et la je n'ai jamais eu de problème.

    Donc ma question est : y a t il une subtilité quand on utilise plusieurs GW sur un seul port WAN ...

    Encore merci par avance pour vos conseils

    Cordialement

    Benjamin



  • Rapidement. Ce type de besoin se traite en général via Policy Routing.



  • Merci pour la réponse.

    J'ai bien créé une Rule pour les clients LAN avec comme gateway mon groupe GRP_INTERNET. (Dans Advanced Options de ma Rule)

    et pour mon client OpenVPN j'ai mis comme interface mon GRP_VPN.

    J'ai peut etre mal compris le "Policy Routing" du PFsense.

    Merci pour l'aide



  • Bonsoir,

    Perso dans le même cas j'opterai pour la mise en place de Vlan sur wan.
    1 Vlan par lien, du coup côté pF ça donne 1 interface pour chacun  ;)



  • Sauf si j'ai mal compris ton problème, pour moi le fonctionnement que tu décris est normal:
    les "routing policies" s'appliquent  ;) et l'ordre des règle de FW également.

    et la solution consiste, toujours si je comprends bien, simplement à écrire une règle, au sommet de la pile, qui dit:
    "tout ce qui va vers 192.168.200.0/24 (sur les ports de ton choix) utilise le routage par défaut"
    et dans ce cas, tes modems étant directement sur le subnet de ton interface WAN, il n'y a pas de raison que tu n'arrives pas à les joindre, si je comprends bien  8)


Log in to reply