Allowed memory size error



  • This just showed up in the logs after updating from  2.4.3.a.20171124.1434 -> 2.4.3.a.20171125.1557

    /usr/local/pkg/pfblockerng/pfblockerng.inc: New alert found: PHP ERROR: Type: 1, File: /usr/local/pkg/pfblockerng/pfblockerng.inc, Line: 2496, Message: Allowed memory size of 536870912 bytes exhausted (tried to allocate 8192 bytes)

    Then an upgrade to  2.4.3.a.20171125.1557 -> 2.4.3.a.20171126.1725 and so far no memory errors.
    Is there any way to increase the allocated memory to pfblocker?
    I'm on a PC Engines APU2 with plenty of available memory.


  • Moderator

    Just clear the notice for now… I suspect that it doesn't repeat once you clear it...

    Can you try the following patch?
    https://forum.pfsense.org/index.php?topic=110515.60

    The next version of the package has a new function that will improve this issue from repeating...

    Thanks!



  • Will do.
    Thanks!


Log in to reply